aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Config-Setting
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-07-01 15:59:27 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-07-01 15:59:27 +0000
commit727985a6e855684511c96be94a4ec0c2118b7586 (patch)
tree7a39b3509269b6f93f5ea2bc77d92d8bc73bdd6c /devel/p5-Config-Setting
parent304bf86d9af8c2bc92d4f791c2a1bae4c4362fe5 (diff)
downloadports-727985a6e855684511c96be94a4ec0c2118b7586.tar.gz
ports-727985a6e855684511c96be94a4ec0c2118b7586.zip
p5-Config-Setting is a perl module that is designed to provide easy to use
settings files for your project. You subclass the basic Config::Setting class in one of your own modules, and then provide an interface to your code using it. When set up, you can then override the settings on a per-host basis, or even using an environment variable. PR: 28565 Submitted by: Pete Fritchman <petef@databits.net>
Notes
Notes: svn path=/head/; revision=44607
Diffstat (limited to 'devel/p5-Config-Setting')
-rw-r--r--devel/p5-Config-Setting/Makefile26
-rw-r--r--devel/p5-Config-Setting/distinfo1
-rw-r--r--devel/p5-Config-Setting/pkg-comment1
-rw-r--r--devel/p5-Config-Setting/pkg-descr16
-rw-r--r--devel/p5-Config-Setting/pkg-plist9
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/p5-Config-Setting/Makefile b/devel/p5-Config-Setting/Makefile
new file mode 100644
index 000000000000..3b4fd91c2087
--- /dev/null
+++ b/devel/p5-Config-Setting/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Config-Setting
+# Date created: 1 July 2001
+# Whom: petef@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-Setting
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= http://www.myrddin.demon.co.uk/dist/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Config::Setting.3 \
+ Config::Setting::Fileprovider.3 \
+ Config::Setting::IniParser.3 \
+ Config::Setting::XMLParser.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-Setting/distinfo b/devel/p5-Config-Setting/distinfo
new file mode 100644
index 000000000000..69c62846deae
--- /dev/null
+++ b/devel/p5-Config-Setting/distinfo
@@ -0,0 +1 @@
+MD5 (Config-Setting-0.01.tar.gz) = 99296fec870ad23e05f30a3c9751e935
diff --git a/devel/p5-Config-Setting/pkg-comment b/devel/p5-Config-Setting/pkg-comment
new file mode 100644
index 000000000000..85f612c84f83
--- /dev/null
+++ b/devel/p5-Config-Setting/pkg-comment
@@ -0,0 +1 @@
+A class that provides an easy interface to use config files
diff --git a/devel/p5-Config-Setting/pkg-descr b/devel/p5-Config-Setting/pkg-descr
new file mode 100644
index 000000000000..48eaf1697e68
--- /dev/null
+++ b/devel/p5-Config-Setting/pkg-descr
@@ -0,0 +1,16 @@
+A perl module that is designed to provide easy to use settings
+files for your project. You subclass the basic Config::Setting
+class in one of your own modules, and then provide an interface to
+your code using it. When set up, you can then override the settings
+on a per-host basis, or even using an environment variable.
+
+By default a win.ini style of configuration is used, but this can
+be overridden and an XML based configuration is also included. The
+access mechanism can also be overridden, the setting don't have to
+come from a file, but (maybe) from a website. You'll have to write
+your own there, though.
+
+WWW: http://www.myrddin.demon.co.uk/Config-Setting.html
+
+- Pete
+petef@databits.net
diff --git a/devel/p5-Config-Setting/pkg-plist b/devel/p5-Config-Setting/pkg-plist
new file mode 100644
index 000000000000..1f233d35343a
--- /dev/null
+++ b/devel/p5-Config-Setting/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/Config/Setting.pm
+lib/perl5/site_perl/%%PERL_VER%%/Config/Setting/FileProvider.pm
+lib/perl5/site_perl/%%PERL_VER%%/Config/Setting/IniParser.pm
+lib/perl5/site_perl/%%PERL_VER%%/Config/Setting/XMLParser.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config/Setting/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config/Setting
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Config/Setting
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Config 2>/dev/null || true