aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Config-Tiny
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-05-18 13:54:21 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-05-18 13:54:21 +0000
commit6d2c80a2a3573729c478e8a5b486aa56edabf61a (patch)
tree1ee4ffe671b4282602587f6f22cafe2738e40def /devel/p5-Config-Tiny
parent30a0834e3460204dd24861cda15ce2c759314bfa (diff)
downloadports-6d2c80a2a3573729c478e8a5b486aa56edabf61a.tar.gz
ports-6d2c80a2a3573729c478e8a5b486aa56edabf61a.zip
Add p5-Config-Tiny 0.3,
read/Write .ini style files with as little code as possible.
Notes
Notes: svn path=/head/; revision=81244
Diffstat (limited to 'devel/p5-Config-Tiny')
-rw-r--r--devel/p5-Config-Tiny/Makefile22
-rw-r--r--devel/p5-Config-Tiny/distinfo1
-rw-r--r--devel/p5-Config-Tiny/pkg-descr14
-rw-r--r--devel/p5-Config-Tiny/pkg-plist5
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/p5-Config-Tiny/Makefile b/devel/p5-Config-Tiny/Makefile
new file mode 100644
index 000000000000..d43d98c1c0cd
--- /dev/null
+++ b/devel/p5-Config-Tiny/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Config-Tiny
+# Date created: 11 December 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-Tiny
+PORTVERSION= 0.3
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Read/Write .ini style files with as little code as possible
+
+PERL_CONFIGURE= yes
+
+MAN3= Config::Tiny.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-Tiny/distinfo b/devel/p5-Config-Tiny/distinfo
new file mode 100644
index 000000000000..05ad7041491a
--- /dev/null
+++ b/devel/p5-Config-Tiny/distinfo
@@ -0,0 +1 @@
+MD5 (Config-Tiny-0.3.tar.gz) = bc35ff26c49c54e009f3e0e419f126e4
diff --git a/devel/p5-Config-Tiny/pkg-descr b/devel/p5-Config-Tiny/pkg-descr
new file mode 100644
index 000000000000..1e71c93093c1
--- /dev/null
+++ b/devel/p5-Config-Tiny/pkg-descr
@@ -0,0 +1,14 @@
+Config::Tiny is a perl class to read and write .ini style configuration
+files with as little code as possible, reducing load time and memory
+overhead. Memory usage is normally scoffed at in Perl, but in my
+opinion should be at least kept in mind.
+
+This module is primarily for reading human written files, and anything
+we write shouldn't need to have documentation/comments. If you need
+something with more power, move up to Config::Simple, Config::General or
+one of the many other Config:: modules.
+
+WWW: http://search.cpan.org/dist/Config-Tiny/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-Config-Tiny/pkg-plist b/devel/p5-Config-Tiny/pkg-plist
new file mode 100644
index 000000000000..e2ff4e74ad25
--- /dev/null
+++ b/devel/p5-Config-Tiny/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Tiny/.packlist
+%%SITE_PERL%%/Config/Tiny.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Tiny
+@unexec rmdir %D/%%SITE_PERL%%/Config 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config 2>/dev/null || true