aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Context-Preserve/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-05-12 06:23:34 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-05-12 06:23:34 +0000
commitaf9daeabe0d639efc74bea86a99a4159d6e1a42a (patch)
tree5b0f8424a017a6aa20bf4aeb0af724127413b146 /devel/p5-Context-Preserve/Makefile
parent2c3a3129701c8ac6b0f7c4921071847bc7997b96 (diff)
downloadports-af9daeabe0d639efc74bea86a99a4159d6e1a42a.tar.gz
ports-af9daeabe0d639efc74bea86a99a4159d6e1a42a.zip
Add p5-Context-Preserve 0.01, run code after a subroutine call,
preserving the context the subroutine.
Notes
Notes: svn path=/head/; revision=233746
Diffstat (limited to 'devel/p5-Context-Preserve/Makefile')
-rw-r--r--devel/p5-Context-Preserve/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/p5-Context-Preserve/Makefile b/devel/p5-Context-Preserve/Makefile
new file mode 100644
index 000000000000..b56eb14d0d8d
--- /dev/null
+++ b/devel/p5-Context-Preserve/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Context-Preserve
+# Date created: 12 May 2009
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Context-Preserve
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/J/JR/JROCKWAY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Run code after a subroutine call, preserving the context the subroutine
+
+PERL_CONFIGURE= yes
+
+MAN3= Context::Preserve.3
+
+.include <bsd.port.mk>