aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Coro
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-03-07 09:03:59 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-03-07 09:03:59 +0000
commit584ba9813e35ccdfe0c622519308c5c01c38b8a2 (patch)
treea29656836f835c6acd3d6a7ccb740e9d103cd17b /devel/p5-Coro
parentded1de065b4d5b58b5ccb3715db0925994665265 (diff)
downloadports-584ba9813e35ccdfe0c622519308c5c01c38b8a2.tar.gz
ports-584ba9813e35ccdfe0c622519308c5c01c38b8a2.zip
Update to 3.5.1.
Notes
Notes: svn path=/head/; revision=186779
Diffstat (limited to 'devel/p5-Coro')
-rw-r--r--devel/p5-Coro/Makefile2
-rw-r--r--devel/p5-Coro/distinfo6
-rw-r--r--devel/p5-Coro/files/patch-Coro-Makefile.PL29
-rw-r--r--devel/p5-Coro/pkg-plist10
4 files changed, 24 insertions, 23 deletions
diff --git a/devel/p5-Coro/Makefile b/devel/p5-Coro/Makefile
index 0e6f6c6cffe7..f8c47bea2a4b 100644
--- a/devel/p5-Coro/Makefile
+++ b/devel/p5-Coro/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Coro
-PORTVERSION= 3.4.1
+PORTVERSION= 3.5.1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
diff --git a/devel/p5-Coro/distinfo b/devel/p5-Coro/distinfo
index 1ac308d9633c..e94b36106fe1 100644
--- a/devel/p5-Coro/distinfo
+++ b/devel/p5-Coro/distinfo
@@ -1,3 +1,3 @@
-MD5 (Coro-3.41.tar.gz) = d294dde59c19e22fa63a23d6c9dd9580
-SHA256 (Coro-3.41.tar.gz) = d008adaca0255194b125ddc6bd2e7b3dae40d7a7f2c040fb16c3f18c29e87f88
-SIZE (Coro-3.41.tar.gz) = 67398
+MD5 (Coro-3.51.tar.gz) = b94429cff05cde91ac82ed95ada4ed56
+SHA256 (Coro-3.51.tar.gz) = b04305cd34d7657a5ee00a21ee53fdff8aec39778c5e8768aaa6534212b064ce
+SIZE (Coro-3.51.tar.gz) = 68250
diff --git a/devel/p5-Coro/files/patch-Coro-Makefile.PL b/devel/p5-Coro/files/patch-Coro-Makefile.PL
index 0b5e04fd491f..eb3fad881f81 100644
--- a/devel/p5-Coro/files/patch-Coro-Makefile.PL
+++ b/devel/p5-Coro/files/patch-Coro-Makefile.PL
@@ -1,6 +1,6 @@
---- Coro/Makefile.PL.orig Fri Dec 22 05:06:26 2006
-+++ Coro/Makefile.PL Fri Jan 5 15:12:19 2007
-@@ -20,9 +20,7 @@
+--- Coro/Makefile.PL.orig Wed Mar 7 09:39:09 2007
++++ Coro/Makefile.PL Wed Mar 7 09:42:08 2007
+@@ -20,9 +20,7 @@ maintainer :)
EOF
@@ -10,51 +10,52 @@
$DEFINE .= " -DHAVE_MMAP" if $Config{d_mmap} eq "define" && $Config{d_munmap} eq "define";
-@@ -88,9 +86,7 @@
+@@ -88,10 +86,7 @@ EOF
retry:
-my $r = prompt "Use which implementation,\n" .
- "<s>etjmp/longjump, <u>context, <i>rix, <l>inux or <w>indows?",
- $iface;
-+my $r = 'u';
- $iface = lc $1 if $r =~ /(\S)/;
+-$iface = lc $1 if $r =~ /(\S)/;
++$iface = 'u';
if ($iface eq "u") {
-@@ -145,7 +141,7 @@
+ $DEFINE .= " -DCORO_UCONTEXT";
+@@ -145,7 +140,7 @@ The default should be fine.
EOF
-my $stacksize = prompt ("C stack size factor?", "16384");
+my $stacksize = 65536;
- $DEFINE .= " -DSTACKSIZE=$stacksize";
+ $DEFINE .= " -DCORO_STACKSIZE=$stacksize";
print "using a stacksize of $stacksize * sizeof(long)\n";
-@@ -172,7 +168,7 @@
+@@ -172,7 +167,7 @@ The default, as usual, should be just fi
EOF
-my $stackguard = prompt ("Number of guard pages (0 disables)?", "4");
+my $stackguard = 4;
- $DEFINE .= " -DSTACKGUARD=$stackguard";
+ $DEFINE .= " -DCORO_STACKGUARD=$stackguard";
print <<EOF;
-@@ -190,8 +186,7 @@
+@@ -190,8 +185,7 @@ the safe choice.
EOF
-my $valgrind = prompt ("Enable valgrind support (y/n)?",
- -r "/usr/include/valgrind/valgrind.h" ? "y" : "n");
+my $valgrind = 'n';
- $DEFINE .= " -DUSE_VALGRIND=1" if $valgrind =~ /[yY]/;
+ $DEFINE .= " -DCORO_USE_VALGRIND=1" if $valgrind =~ /[yY]/;
-@@ -208,7 +203,7 @@
+@@ -208,7 +202,7 @@ should enable it only as a last resort.
EOF
-my $use_internals = prompt ("Prefer perl functions over coro functions (y/n)?", "n");
+my $use_internals = 'n';
- $DEFINE .= " -DPREFER_PERL_FUNCTIONS=1" if $use_internals =~ /[yY]/;
+ $DEFINE .= " -DCORO_PREFER_PERL_FUNCTIONS=1" if $use_internals =~ /[yY]/;
print <<EOF;
diff --git a/devel/p5-Coro/pkg-plist b/devel/p5-Coro/pkg-plist
index 2471deb15f51..59edc818023e 100644
--- a/devel/p5-Coro/pkg-plist
+++ b/devel/p5-Coro/pkg-plist
@@ -34,8 +34,8 @@
%%EXAMPLESDIR%%/readline
@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Coro/State
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Coro/Event
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Coro
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Coro
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Coro/State
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Coro/Event
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Coro
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Coro