aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Coro
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2007-06-16 18:00:20 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2007-06-16 18:00:20 +0000
commit7f13d552ff786dd26ce2f7df54b83a76ee4df475 (patch)
tree59151e80c48d6a1ddc8ebdf1d37263327e6f9cec /devel/p5-Coro
parentcd8f325e58acfdeaeaf4bf6f0212214532b305df (diff)
downloadports-7f13d552ff786dd26ce2f7df54b83a76ee4df475.tar.gz
ports-7f13d552ff786dd26ce2f7df54b83a76ee4df475.zip
- update to 3.6.3
Notes
Notes: svn path=/head/; revision=193682
Diffstat (limited to 'devel/p5-Coro')
-rw-r--r--devel/p5-Coro/Makefile6
-rw-r--r--devel/p5-Coro/distinfo6
-rw-r--r--devel/p5-Coro/files/patch-Coro-Makefile.PL18
3 files changed, 15 insertions, 15 deletions
diff --git a/devel/p5-Coro/Makefile b/devel/p5-Coro/Makefile
index b9852d003894..047042ac5cb9 100644
--- a/devel/p5-Coro/Makefile
+++ b/devel/p5-Coro/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Coro
-PORTVERSION= 3.6.2
+PORTVERSION= 3.6.3
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
@@ -15,10 +15,10 @@ PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(.)$/\1/}
MAINTAINER= perl@FreeBSD.org
-COMMENT= Coro - coroutine process abstraction for perl
+COMMENT= Coroutine process abstraction for perl
RUN_DEPENDS= p5-Event>=0.89:${PORTSDIR}/devel/p5-Event \
- ${SITE_PERL}/AnyEvent.pm:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-AnyEvent>=2.5.1:${PORTSDIR}/devel/p5-AnyEvent \
${SITE_PERL}/${PERL_ARCH}/IO/AIO.pm:${PORTSDIR}/devel/p5-IO-AIO
BUILD_DEPENDS= ${RUN_DEPENDS}
diff --git a/devel/p5-Coro/distinfo b/devel/p5-Coro/distinfo
index 02e83095e990..fb0bb07646aa 100644
--- a/devel/p5-Coro/distinfo
+++ b/devel/p5-Coro/distinfo
@@ -1,3 +1,3 @@
-MD5 (Coro-3.62.tar.gz) = 0e728a5013c4ac288bdb9945136d4c22
-SHA256 (Coro-3.62.tar.gz) = 9b88731befd1c7f0fc4e98407fa21b621dd6cff40180ffdda612d4cf42d6ac66
-SIZE (Coro-3.62.tar.gz) = 71157
+MD5 (Coro-3.63.tar.gz) = 170165d6d463e1d6149654304a47ba0c
+SHA256 (Coro-3.63.tar.gz) = 20ee87750183a9cad3af2393d35f8d49e20aff2e9ce0caf050026f368300db9d
+SIZE (Coro-3.63.tar.gz) = 71970
diff --git a/devel/p5-Coro/files/patch-Coro-Makefile.PL b/devel/p5-Coro/files/patch-Coro-Makefile.PL
index eb3fad881f81..58ab1ec02f4d 100644
--- a/devel/p5-Coro/files/patch-Coro-Makefile.PL
+++ b/devel/p5-Coro/files/patch-Coro-Makefile.PL
@@ -1,6 +1,6 @@
---- Coro/Makefile.PL.orig Wed Mar 7 09:39:09 2007
-+++ Coro/Makefile.PL Wed Mar 7 09:42:08 2007
-@@ -20,9 +20,7 @@ maintainer :)
+--- Coro/Makefile.PL.orig Sun Jun 17 01:31:38 2007
++++ Coro/Makefile.PL Sun Jun 17 01:35:46 2007
+@@ -20,9 +20,7 @@
EOF
@@ -10,19 +10,19 @@
$DEFINE .= " -DHAVE_MMAP" if $Config{d_mmap} eq "define" && $Config{d_munmap} eq "define";
-@@ -88,10 +86,7 @@ EOF
+@@ -104,10 +102,7 @@
retry:
-my $r = prompt "Use which implementation,\n" .
-- "<s>etjmp/longjump, <u>context, <i>rix, <l>inux or <w>indows?",
+- "<s>et/longjump, <u>context, <a>ssembly, <i>rix, <l>inux or <w>indows?",
- $iface;
-$iface = lc $1 if $r =~ /(\S)/;
+$iface = 'u';
if ($iface eq "u") {
$DEFINE .= " -DCORO_UCONTEXT";
-@@ -145,7 +140,7 @@ The default should be fine.
+@@ -165,7 +160,7 @@
EOF
@@ -31,7 +31,7 @@
$DEFINE .= " -DCORO_STACKSIZE=$stacksize";
print "using a stacksize of $stacksize * sizeof(long)\n";
-@@ -172,7 +167,7 @@ The default, as usual, should be just fi
+@@ -192,7 +187,7 @@
EOF
@@ -40,7 +40,7 @@
$DEFINE .= " -DCORO_STACKGUARD=$stackguard";
print <<EOF;
-@@ -190,8 +185,7 @@ the safe choice.
+@@ -210,8 +205,7 @@
EOF
@@ -50,7 +50,7 @@
$DEFINE .= " -DCORO_USE_VALGRIND=1" if $valgrind =~ /[yY]/;
-@@ -208,7 +202,7 @@ should enable it only as a last resort.
+@@ -228,7 +222,7 @@
EOF