aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-TreeDumper/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-02 14:32:40 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-02 14:32:40 +0000
commit2699799190a8b0b4bf6680558098e8a3408b8c2e (patch)
treea76c38ec5b1f247cd6e37113f217502661aebd5e /devel/p5-Data-TreeDumper/Makefile
parent1d8a6281749b840a00aef3661d9a8d28007e297c (diff)
downloadports-2699799190a8b0b4bf6680558098e8a3408b8c2e.tar.gz
ports-2699799190a8b0b4bf6680558098e8a3408b8c2e.zip
Add p5-Data-TreeDumper 0.15, dumps a data structure in a tree fashion.
PR: ports/69883 Submitted by: Aaron Dalton <aaron@daltons.ca>
Notes
Notes: svn path=/head/; revision=115268
Diffstat (limited to 'devel/p5-Data-TreeDumper/Makefile')
-rw-r--r--devel/p5-Data-TreeDumper/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/devel/p5-Data-TreeDumper/Makefile b/devel/p5-Data-TreeDumper/Makefile
new file mode 100644
index 000000000000..27145fd9aeba
--- /dev/null
+++ b/devel/p5-Data-TreeDumper/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Data::TreeDumper
+# Date created: 1 August 2004
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-TreeDumper
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Dumps a data structure in a tree fashion
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/Size.pm:${PORTSDIR}/devel/p5-Term-Size \
+ ${SITE_PERL}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap \
+ ${SITE_PERL}/${PERL_ARCH}/Devel/Size.pm:${PORTSDIR}/devel/p5-Devel-Size
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Data::TreeDumper.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ ${PERL} -pi -e 's/^our (\S+)/use vars q{$$1};$$1/g;' \
+ -e '$$_ = "" if /warnings|5.006/;' \
+ -e 's/}\(/}->(/g;' \
+ -e '$$_ .= "->" if $$. == 428;' \
+ ${WRKSRC}/TreeDumper.pm
+.endif
+
+.include <bsd.port.post.mk>