aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-UUID
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-08-31 08:18:46 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-08-31 08:18:46 +0000
commit0659e64d626481bbea00af3a4c8419c779816c74 (patch)
tree5ff4a633cf9f2d03113936727c3454e314cc0392 /devel/p5-Data-UUID
parent47846ba2684d4380079fbe8af0508e24b83cd293 (diff)
downloadports-0659e64d626481bbea00af3a4c8419c779816c74.tar.gz
ports-0659e64d626481bbea00af3a4c8419c779816c74.zip
Updated to 0.11
Notes
Notes: svn path=/head/; revision=88175
Diffstat (limited to 'devel/p5-Data-UUID')
-rw-r--r--devel/p5-Data-UUID/Makefile13
-rw-r--r--devel/p5-Data-UUID/distinfo2
-rw-r--r--devel/p5-Data-UUID/files/patch-UUID.pm51
-rw-r--r--devel/p5-Data-UUID/files/patch-typemap11
4 files changed, 12 insertions, 65 deletions
diff --git a/devel/p5-Data-UUID/Makefile b/devel/p5-Data-UUID/Makefile
index 1a859373d006..cd235665b802 100644
--- a/devel/p5-Data-UUID/Makefile
+++ b/devel/p5-Data-UUID/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Data-UUID
-PORTVERSION= 0.09
+PORTVERSION= 0.11
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Data
@@ -20,4 +20,13 @@ CONFIGURE_ARGS= </dev/null
MAN3= Data::UUID.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${PERL_LEVEL} < 500601
+ @${PERL} -pi -e '$$_="" if $$.==31' ${WRKSRC}/UUID.pm
+ @${PERL} -pi -e '$$_=~s/INT2PTR\(\$$type,/(\$$type)(/ if $$.==8' \
+ ${WRKSRC}/typemap
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-UUID/distinfo b/devel/p5-Data-UUID/distinfo
index 4a147341e66f..510f389f5821 100644
--- a/devel/p5-Data-UUID/distinfo
+++ b/devel/p5-Data-UUID/distinfo
@@ -1 +1 @@
-MD5 (Data-UUID-0.09.tar.gz) = 7a95b12170b539b2842b5fc4de35aea1
+MD5 (Data-UUID-0.11.tar.gz) = 669b9935baf1753eca784dd30b9ad4b1
diff --git a/devel/p5-Data-UUID/files/patch-UUID.pm b/devel/p5-Data-UUID/files/patch-UUID.pm
deleted file mode 100644
index 4f9e539ed43b..000000000000
--- a/devel/p5-Data-UUID/files/patch-UUID.pm
+++ /dev/null
@@ -1,51 +0,0 @@
---- UUID.pm.orig Mon May 27 18:11:13 2002
-+++ UUID.pm Mon May 27 18:12:25 2002
-@@ -1,15 +1,14 @@
- package Data::UUID;
-
--use 5.006;
- use strict;
--use warnings;
- use Carp;
-
- require Exporter;
- require DynaLoader;
- use AutoLoader;
-
--our @ISA = qw(Exporter DynaLoader);
-+use vars qw(@ISA %EXPORT_TAGS @EXPORT_OK @EXPORT $VERSION $AUTOLOAD);
-+@ISA = qw(Exporter DynaLoader);
-
- # Items to export into callers namespace by default. Note: do not export
- # names by default without a very good reason. Use EXPORT_OK instead.
-@@ -18,18 +17,18 @@
- # This allows declaration use Data::UUID ':all';
- # If you do not need this, moving things directly into @EXPORT or @EXPORT_OK
- # will save memory.
--our %EXPORT_TAGS = ( 'all' => [ qw(
-+%EXPORT_TAGS = ( 'all' => [ qw(
- NameSpace_DNS
- NameSpace_OID
- NameSpace_URL
- NameSpace_X500
- ) ] );
-
--our @EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
-+@EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
-
--our @EXPORT = qw(
-+@EXPORT = qw(
- );
--our $VERSION = '0.09';
-+$VERSION = '0.09';
-
- sub AUTOLOAD {
- # This AUTOLOAD is used to 'autoload' constants from the constant()
-@@ -37,7 +36,6 @@
- # to the AUTOLOAD in AutoLoader.
-
- my $constname;
-- our $AUTOLOAD;
- ($constname = $AUTOLOAD) =~ s/.*:://;
- croak "& not defined" if $constname eq 'constant';
- my $val = constant($constname, @_ ? $_[0] : 0);
diff --git a/devel/p5-Data-UUID/files/patch-typemap b/devel/p5-Data-UUID/files/patch-typemap
deleted file mode 100644
index 00774659f982..000000000000
--- a/devel/p5-Data-UUID/files/patch-typemap
+++ /dev/null
@@ -1,11 +0,0 @@
---- typemap.orig Tue Dec 11 01:20:31 2001
-+++ typemap Mon Jan 28 19:56:30 2002
-@@ -5,7 +5,7 @@
- T_PTRUUID
- if (sv_derived_from($arg, \"Data::UUID\")) {
- IV tmp = SvIV((SV*)SvRV($arg));
-- $var = INT2PTR($type,tmp);
-+ $var = ($type)(tmp);
- }
- else
- croak(\"$var is not of type Data::UUID\")