aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-UUID
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-05-27 14:18:15 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-05-27 14:18:15 +0000
commitb3d64975635daaddf04d03dff77df2ee4cc6bbda (patch)
treef1339cffc60352145f2aa98be1506dc3df2e546f /devel/p5-Data-UUID
parente9bf4e61f0765f02aedb9a70f885a97877e31fb9 (diff)
downloadports-b3d64975635daaddf04d03dff77df2ee4cc6bbda.tar.gz
ports-b3d64975635daaddf04d03dff77df2ee4cc6bbda.zip
Add p5-Data-UUID 0.06,
module for generating Globally/Universally Unique Identifiers (GUIDs/UUIDs).
Notes
Notes: svn path=/head/; revision=60127
Diffstat (limited to 'devel/p5-Data-UUID')
-rw-r--r--devel/p5-Data-UUID/Makefile23
-rw-r--r--devel/p5-Data-UUID/distinfo1
-rw-r--r--devel/p5-Data-UUID/files/patch-UUID.pm51
-rw-r--r--devel/p5-Data-UUID/files/patch-typemap11
-rw-r--r--devel/p5-Data-UUID/pkg-comment1
-rw-r--r--devel/p5-Data-UUID/pkg-descr20
-rw-r--r--devel/p5-Data-UUID/pkg-plist8
7 files changed, 115 insertions, 0 deletions
diff --git a/devel/p5-Data-UUID/Makefile b/devel/p5-Data-UUID/Makefile
new file mode 100644
index 000000000000..95c6760981c2
--- /dev/null
+++ b/devel/p5-Data-UUID/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Data::UUID
+# Date created: 28 Jan 2002
+# Whom: Sergey Skvortsov <skv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-UUID
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= </dev/null
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Data::UUID.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-UUID/distinfo b/devel/p5-Data-UUID/distinfo
new file mode 100644
index 000000000000..b8176815daf3
--- /dev/null
+++ b/devel/p5-Data-UUID/distinfo
@@ -0,0 +1 @@
+MD5 (Data-UUID-0.06.tar.gz) = 928358ad89761125374b9cdacf8caaa1
diff --git a/devel/p5-Data-UUID/files/patch-UUID.pm b/devel/p5-Data-UUID/files/patch-UUID.pm
new file mode 100644
index 000000000000..76eef6bea896
--- /dev/null
+++ b/devel/p5-Data-UUID/files/patch-UUID.pm
@@ -0,0 +1,51 @@
+--- UUID.pm.orig Mon May 27 18:11:13 2002
++++ UUID.pm Mon May 27 18:12:25 2002
+@@ -1,15 +1,14 @@
+ package Data::UUID;
+
+-use 5.006;
+ use strict;
+-use warnings;
+ use Carp;
+
+ require Exporter;
+ require DynaLoader;
+ use AutoLoader;
+
+-our @ISA = qw(Exporter DynaLoader);
++use vars qw(@ISA %EXPORT_TAGS @EXPORT_OK @EXPORT $VERSION $AUTOLOAD);
++@ISA = qw(Exporter DynaLoader);
+
+ # Items to export into callers namespace by default. Note: do not export
+ # names by default without a very good reason. Use EXPORT_OK instead.
+@@ -18,18 +17,18 @@
+ # This allows declaration use Data::UUID ':all';
+ # If you do not need this, moving things directly into @EXPORT or @EXPORT_OK
+ # will save memory.
+-our %EXPORT_TAGS = ( 'all' => [ qw(
++%EXPORT_TAGS = ( 'all' => [ qw(
+ NameSpace_DNS
+ NameSpace_OID
+ NameSpace_URL
+ NameSpace_X500
+ ) ] );
+
+-our @EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
++@EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
+
+-our @EXPORT = qw(
++@EXPORT = qw(
+ );
+-our $VERSION = '0.06';
++$VERSION = '0.06';
+
+ sub AUTOLOAD {
+ # This AUTOLOAD is used to 'autoload' constants from the constant()
+@@ -37,7 +36,6 @@
+ # to the AUTOLOAD in AutoLoader.
+
+ my $constname;
+- our $AUTOLOAD;
+ ($constname = $AUTOLOAD) =~ s/.*:://;
+ croak "& not defined" if $constname eq 'constant';
+ my $val = constant($constname, @_ ? $_[0] : 0);
diff --git a/devel/p5-Data-UUID/files/patch-typemap b/devel/p5-Data-UUID/files/patch-typemap
new file mode 100644
index 000000000000..00774659f982
--- /dev/null
+++ b/devel/p5-Data-UUID/files/patch-typemap
@@ -0,0 +1,11 @@
+--- typemap.orig Tue Dec 11 01:20:31 2001
++++ typemap Mon Jan 28 19:56:30 2002
+@@ -5,7 +5,7 @@
+ T_PTRUUID
+ if (sv_derived_from($arg, \"Data::UUID\")) {
+ IV tmp = SvIV((SV*)SvRV($arg));
+- $var = INT2PTR($type,tmp);
++ $var = ($type)(tmp);
+ }
+ else
+ croak(\"$var is not of type Data::UUID\")
diff --git a/devel/p5-Data-UUID/pkg-comment b/devel/p5-Data-UUID/pkg-comment
new file mode 100644
index 000000000000..7820649994cd
--- /dev/null
+++ b/devel/p5-Data-UUID/pkg-comment
@@ -0,0 +1 @@
+Module for generating Globally/Universally Unique Identifiers (GUIDs/UUIDs)
diff --git a/devel/p5-Data-UUID/pkg-descr b/devel/p5-Data-UUID/pkg-descr
new file mode 100644
index 000000000000..3fa8a05617f1
--- /dev/null
+++ b/devel/p5-Data-UUID/pkg-descr
@@ -0,0 +1,20 @@
+This module provides a framework for generating UUIDs (Universally
+Unique Identifiers, also known as GUIDs (Globally Unique Identifiers).
+A UUID is 128 bits long, and is guaranteed to be different from all
+other UUIDs/GUIDs generated until 3400 A.D. Currently many different
+technologies rely on UUIDs to provide unique identity for various
+software components.
+
+The algorithm for UUID generation, used by this extension, is described
+in the Internet Draft "UUIDs and GUIDs" by Paul J. Leach and Rich Salz.
+It provides reasonably efficient and reliable framework for generating
+UUIDs and supports fairly high allocation rates - 10 million per second
+per machine, and therefore, is suitable for identifying both - extremely
+short-lived and very persistent objects on a given system as well as
+across the network.
+
+WWW: http://search.cpan.org/search?dist=Data-UUID
+WWW: http://www.globecom.net/ietf/draft/draft-leach-uuids-guids-01.txt
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-Data-UUID/pkg-plist b/devel/p5-Data-UUID/pkg-plist
new file mode 100644
index 000000000000..c9c067d62ca9
--- /dev/null
+++ b/devel/p5-Data-UUID/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data/UUID/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Data/UUID.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data/UUID/UUID.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data/UUID/UUID.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data/UUID/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data/UUID
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Data 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true