aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Date-Manip
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1997-04-28 18:49:15 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1997-04-28 18:49:15 +0000
commite09fa3556cb3f54c5f43db59e168ae848cabe753 (patch)
tree1626106214d123ec3723a9546b0271afa2c2c59c /devel/p5-Date-Manip
parent80ad3c94afdc8752e65f5bfffcaf1e70a11d8c90 (diff)
downloadports-e09fa3556cb3f54c5f43db59e168ae848cabe753.tar.gz
ports-e09fa3556cb3f54c5f43db59e168ae848cabe753.zip
Import of p5-Date-Manip, a module for doing date manipulation in perl.
Notes
Notes: svn path=/head/; revision=6356
Diffstat (limited to 'devel/p5-Date-Manip')
-rw-r--r--devel/p5-Date-Manip/Makefile26
-rw-r--r--devel/p5-Date-Manip/distinfo1
-rw-r--r--devel/p5-Date-Manip/pkg-comment1
-rw-r--r--devel/p5-Date-Manip/pkg-descr56
-rw-r--r--devel/p5-Date-Manip/pkg-plist4
5 files changed, 88 insertions, 0 deletions
diff --git a/devel/p5-Date-Manip/Makefile b/devel/p5-Date-Manip/Makefile
new file mode 100644
index 000000000000..faca953312ba
--- /dev/null
+++ b/devel/p5-Date-Manip/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Date-Manip
+# Version required: 5.10
+# Date created: April 28th 1996
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= DateManip-5.10
+PKGNAME= p5-Date-Manip-5.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Date
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
+RUN_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
+
+MAN3= Date::Manip.3
+MANPREFIX= ${PREFIX}/lib/perl5
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Date-Manip/distinfo b/devel/p5-Date-Manip/distinfo
new file mode 100644
index 000000000000..ca6f1819784f
--- /dev/null
+++ b/devel/p5-Date-Manip/distinfo
@@ -0,0 +1 @@
+MD5 (DateManip-5.10.tar.gz) = c06b976c7f980034a059161347e92098
diff --git a/devel/p5-Date-Manip/pkg-comment b/devel/p5-Date-Manip/pkg-comment
new file mode 100644
index 000000000000..eeb522409894
--- /dev/null
+++ b/devel/p5-Date-Manip/pkg-comment
@@ -0,0 +1 @@
+perl5 module containing date manipulation routines
diff --git a/devel/p5-Date-Manip/pkg-descr b/devel/p5-Date-Manip/pkg-descr
new file mode 100644
index 000000000000..3717ae972091
--- /dev/null
+++ b/devel/p5-Date-Manip/pkg-descr
@@ -0,0 +1,56 @@
+ This is a set of routines designed to make any common
+ date/time manipulation easy to do. Operations such as
+ comparing two times, calculating a time a given amount of
+ time from another, or parsing international times are all
+ easily done.
+
+ Date::Manip deals only with the Gregorian calendar (the
+ one currently in use). The Julian calendar defined leap
+ years as every 4th year. The Gregorian calendar improved
+ this by making every 100th year NOT a leap year, unless it
+ was also the 400th year. The Gregorian calendar has been
+ extrapolated back to the year 1000 AD and forward to the
+ year 9999 AD. Note that in historical context, the Julian
+ calendar was in use until 1582 when the Gregorian calendar
+ was adopted by the Catholic church. Protestant countries
+ did not accept it until later; Germany and Netherlands in
+ 1698, British Empire in 1752, Russia in 1918. Note that
+ the Gregorian calendar is itself imperfect. Each year is
+ on average 26 seconds too long, which means that every
+ 3,323 years, a day should be removed from the calendar.
+ No attempt is made to correct for that.
+
+ Date::Manip is therefore not equipped to truly deal with
+ historacle dates, but should be able to perform
+ (virtually) any operation dealing with a modern time and
+ date.
+
+ Among other things, Date::Manip allow you to:
+
+ 1. Enter a date and be able to choose any format
+ conveniant
+
+ 2. Compare two dates, entered in widely different formats
+ to determine which is earlier
+
+ 3. Extract any information you want from ANY date using a
+ format string similar to the Unix date command
+
+ 4. Determine the amount of time between two dates
+
+ 5. Add a time offset to a date to get a second date (i.e.
+ determine the date 132 days ago or 2 years and 3 months
+ after Jan 2, 1992)
+
+ 6. Work with dates with dates using international formats
+ (foreign month names, 12-10-95 referring to October rather than
+ December, etc.).
+
+ Each of these tasks is trivial (one or two lines at most)
+ with this package.
+
+ Although the word date is used extensively here, it is
+ actually somewhat misleading. Date::Manip works with the
+ full date AND time (year, month, day, hour, minute,
+ second).
+
diff --git a/devel/p5-Date-Manip/pkg-plist b/devel/p5-Date-Manip/pkg-plist
new file mode 100644
index 000000000000..f2562279ce22
--- /dev/null
+++ b/devel/p5-Date-Manip/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/man/man3/Date::Manip.3.gz
+lib/perl5/site_perl/Date/Manip.pm
+lib/perl5/site_perl/i386-freebsd/auto/Date/Manip/.packlist
+@dirrm lib/perl5/site_perl/i386-freebsd/auto/Date/Manip