aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Date-Simple
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2003-06-03 03:45:35 +0000
committerWill Andrews <will@FreeBSD.org>2003-06-03 03:45:35 +0000
commit7fea6e110f487d26ec69cdf1466eb29cea725d74 (patch)
tree0b96c4c383c81f8b4e803d00e1a6805354c90d81 /devel/p5-Date-Simple
parent8e53feeba68bb41e414345a9681eec28e039fe65 (diff)
downloadports-7fea6e110f487d26ec69cdf1466eb29cea725d74.tar.gz
ports-7fea6e110f487d26ec69cdf1466eb29cea725d74.zip
Add p5-Date-Simple 2.04, a simple date object.
PR: 52316 Submitted by: Alexey V. Antipovsky <kemm@in-line.ru>
Notes
Notes: svn path=/head/; revision=82135
Diffstat (limited to 'devel/p5-Date-Simple')
-rw-r--r--devel/p5-Date-Simple/Makefile24
-rw-r--r--devel/p5-Date-Simple/distinfo1
-rw-r--r--devel/p5-Date-Simple/pkg-descr20
-rw-r--r--devel/p5-Date-Simple/pkg-plist10
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/p5-Date-Simple/Makefile b/devel/p5-Date-Simple/Makefile
new file mode 100644
index 000000000000..fb5ec337a94f
--- /dev/null
+++ b/devel/p5-Date-Simple/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Date-Simple
+# Date created: 15 May 2003
+# Whom: Alexey V. Antipovsky <kemm@in-line.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Date-Simple
+PORTVERSION= 2.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/J/JT/JTOBEY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kemm@in-line.ru
+COMMENT= A simple date object
+
+PERL_CONFIGURE= yes
+
+MAN3= Date::Simple.3 Date::Simple::NoXS.3
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Date-Simple/distinfo b/devel/p5-Date-Simple/distinfo
new file mode 100644
index 000000000000..ea1db648aeb8
--- /dev/null
+++ b/devel/p5-Date-Simple/distinfo
@@ -0,0 +1 @@
+MD5 (Date-Simple-2.04.tar.gz) = 38dfba341d083c5059953eed6225c7cd
diff --git a/devel/p5-Date-Simple/pkg-descr b/devel/p5-Date-Simple/pkg-descr
new file mode 100644
index 000000000000..51b0f240733e
--- /dev/null
+++ b/devel/p5-Date-Simple/pkg-descr
@@ -0,0 +1,20 @@
+From Date::Simple(3) man page:
+
+Dates are complex enough without times and timezones. This module may
+be used to create simple date objects. It handles:
+
+Validation:
+ Reject 1999-02-29 but accept 2000-02-29.
+Interval arithmetic:
+ How many days were between two given dates? What date comes N days
+ after today?
+Day-of-week calculation:
+ What day of the week is a given date?
+
+It does NOT deal with hours, minutes, seconds, and time zones.
+
+WWW: http://search.cpan.org/search?dist=Date-Simple
+
+--
+Alexey V. Antipovsky
+kemm@in-line.ru
diff --git a/devel/p5-Date-Simple/pkg-plist b/devel/p5-Date-Simple/pkg-plist
new file mode 100644
index 000000000000..92b0533ff356
--- /dev/null
+++ b/devel/p5-Date-Simple/pkg-plist
@@ -0,0 +1,10 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Date/Simple.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Date/Simple/NoXS.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date/Simple/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date/Simple/Simple.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date/Simple/Simple.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date/Simple
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Date/Simple 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Date 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Date 2>/dev/null || true