aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Format-Flexible/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-14 17:39:36 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-14 17:39:36 +0000
commit3ed3ef1c7f4a10c17fcb2171399160fec222bd4a (patch)
tree6a56144f4a3407f358e958bb539d6ea967a4fc45 /devel/p5-DateTime-Format-Flexible/Makefile
parent68fa655cc34fb027d6cc3007a44b8a726b60e2ca (diff)
downloadports-3ed3ef1c7f4a10c17fcb2171399160fec222bd4a.tar.gz
ports-3ed3ef1c7f4a10c17fcb2171399160fec222bd4a.zip
DateTime::Format::Flexible attempts to take any string you give it
and parse it into a DateTime object. The test file tests 2500+ variations of date/time strings. WWW: http://search.cpan.org/dist/DateTime-Format-Flexible/ PR: ports/135939 (4 of 6) Submitted by: Cezary Morga <cm at therek.net>
Notes
Notes: svn path=/head/; revision=237805
Diffstat (limited to 'devel/p5-DateTime-Format-Flexible/Makefile')
-rw-r--r--devel/p5-DateTime-Format-Flexible/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Format-Flexible/Makefile b/devel/p5-DateTime-Format-Flexible/Makefile
new file mode 100644
index 000000000000..2173b7252583
--- /dev/null
+++ b/devel/p5-DateTime-Format-Flexible/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: devel/p5-DateTime-Format-Flexible
+# Date created: 23 Jun 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-Flexible
+PORTVERSION= 0.09
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Flexibly parse strings and turn them into DateTime objects
+
+RUN_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Format-Builder>=0.74:${PORTSDIR}/devel/p5-DateTime-Format-Builder \
+ p5-DateTime-TimeZone>=0:${PORTSDIR}/devel/p5-DateTime-TimeZone \
+ p5-Readonly>=0.06:${PORTSDIR}/devel/p5-Readonly
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::Flexible.3
+
+.include <bsd.port.mk>