aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-TimeZone/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-06-07 09:48:01 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-06-07 09:48:01 +0000
commit461712ebadddd8a7b321a2aa1a66e12e05277858 (patch)
tree5861a54820ba80f58904505a6a4e468cf0c2b1c9 /devel/p5-DateTime-TimeZone/Makefile
parent5d98269a6525d6b4da1e92745d8ae0f1061d5eb5 (diff)
downloadports-461712ebadddd8a7b321a2aa1a66e12e05277858.tar.gz
ports-461712ebadddd8a7b321a2aa1a66e12e05277858.zip
Add p5-DateTime-TimeZone 0.13,
time zone object base class and factory. PR: 51782 Submitted by: Mathieu Arnold <m@absolight.net>
Notes
Notes: svn path=/head/; revision=82428
Diffstat (limited to 'devel/p5-DateTime-TimeZone/Makefile')
-rw-r--r--devel/p5-DateTime-TimeZone/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/p5-DateTime-TimeZone/Makefile b/devel/p5-DateTime-TimeZone/Makefile
new file mode 100644
index 000000000000..b25ca42dc54b
--- /dev/null
+++ b/devel/p5-DateTime-TimeZone/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-DateTime-TimeZone
+# Date created: 4 mai 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-TimeZone
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Time zone object base class and factory
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Singleton.pm:${PORTSDIR}/devel/p5-Class-Singleton \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::TimeZone.3 \
+ DateTime::TimeZone::UTC.3 \
+ DateTime::TimeZoneCatalog.3 \
+ DateTime::TimeZone::OlsonDB.3 \
+ DateTime::TimeZone::Floating.3
+
+.include <bsd.port.mk>