aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-07-27 12:41:49 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-07-27 12:41:49 +0000
commitfae6badd940e79ccdbeaabc1f6704efd04c8bcc8 (patch)
treed9865b4ad22d5f85da6d8376c9374c82f867cd9a /devel/p5-DateTime/Makefile
parent49cb1cc05da6d3d58cdfa00df86f9a69b497e849 (diff)
downloadports-fae6badd940e79ccdbeaabc1f6704efd04c8bcc8.tar.gz
ports-fae6badd940e79ccdbeaabc1f6704efd04c8bcc8.zip
Update to 0.22
Add some doc
Notes
Notes: svn path=/head/; revision=114868
Diffstat (limited to 'devel/p5-DateTime/Makefile')
-rw-r--r--devel/p5-DateTime/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/devel/p5-DateTime/Makefile b/devel/p5-DateTime/Makefile
index 49cb33302f53..0f358cac2dae 100644
--- a/devel/p5-DateTime/Makefile
+++ b/devel/p5-DateTime/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= DateTime
-PORTVERSION= 0.21.01
+PORTVERSION= 0.22
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DateTime
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(..)$/\1/}
+#DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(..)$/\1/}
MAINTAINER= mat@FreeBSD.org
COMMENT= A date and time object
@@ -28,4 +28,13 @@ PERL_CONFIGURE= yes
MAN3= DateTime.3 DateTime::Duration.3 \
DateTime::Infinite.3 DateTime::LeapSecond.3
+.if !defined(NOPORTDOCS)
+PORTDOCS= CREDITS Changes README TODO
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
.include <bsd.port.mk>