aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Devel-Constants
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-10-10 13:07:02 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-10-10 13:07:02 +0000
commitab681b31166802d957aace9bf76ee5d50270f452 (patch)
treeb34287a73c1b8270ab22c517fe19f803919754c4 /devel/p5-Devel-Constants
parentb4a37e672d764f4644549f1cf4dbb645115a463b (diff)
downloadports-ab681b31166802d957aace9bf76ee5d50270f452.tar.gz
ports-ab681b31166802d957aace9bf76ee5d50270f452.zip
Add p5-Devel-Constants, a Perl module to translate constants back to
their named symbols.
Notes
Notes: svn path=/head/; revision=48649
Diffstat (limited to 'devel/p5-Devel-Constants')
-rw-r--r--devel/p5-Devel-Constants/Makefile22
-rw-r--r--devel/p5-Devel-Constants/distinfo1
-rw-r--r--devel/p5-Devel-Constants/pkg-comment1
-rw-r--r--devel/p5-Devel-Constants/pkg-descr14
-rw-r--r--devel/p5-Devel-Constants/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-Devel-Constants/Makefile b/devel/p5-Devel-Constants/Makefile
new file mode 100644
index 000000000000..093455ac8a04
--- /dev/null
+++ b/devel/p5-Devel-Constants/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: devel/p5-Devel-Constants
+# Date created: 10 October 2001
+# Whom: tobez
+#
+# $FreeBSD$
+#
+
+PORTNAME= Devel-Constants
+PORTVERSION= 0.20
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Devel
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Devel::Constants.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Devel-Constants/distinfo b/devel/p5-Devel-Constants/distinfo
new file mode 100644
index 000000000000..e027be339e32
--- /dev/null
+++ b/devel/p5-Devel-Constants/distinfo
@@ -0,0 +1 @@
+MD5 (Devel-Constants-0.20.tar.gz) = b003f5b5256ce9d9a4c2f905a4b7f834
diff --git a/devel/p5-Devel-Constants/pkg-comment b/devel/p5-Devel-Constants/pkg-comment
new file mode 100644
index 000000000000..03ad3730a5be
--- /dev/null
+++ b/devel/p5-Devel-Constants/pkg-comment
@@ -0,0 +1 @@
+Perl module to translate constants back to their named symbols
diff --git a/devel/p5-Devel-Constants/pkg-descr b/devel/p5-Devel-Constants/pkg-descr
new file mode 100644
index 000000000000..80c28ee360cb
--- /dev/null
+++ b/devel/p5-Devel-Constants/pkg-descr
@@ -0,0 +1,14 @@
+Declaring constants is very convenient for writing programs, but as
+they're often inlined by Perl, retrieving their symbolic names can be
+tricky. This is made worse with lowlevel modules that use constants for
+bit-twiddling.
+
+Devel::Constants makes this much more manageable.
+
+It silently wraps around the constant module, intercepting all constant
+declarations. It builds a hash, associating the values to their names.
+The names can then be retrieved as necessary.
+
+WWW: http://search.cpan.org/search?dist=Devel-Constants
+
+-- Anton
diff --git a/devel/p5-Devel-Constants/pkg-plist b/devel/p5-Devel-Constants/pkg-plist
new file mode 100644
index 000000000000..44afa9a1fd04
--- /dev/null
+++ b/devel/p5-Devel-Constants/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Devel/Constants/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Devel/Constants.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Devel/Constants
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Devel 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Devel 2>/dev/null || true