aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Event-RPC
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-05-17 10:02:24 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-05-17 10:02:24 +0000
commit5d31075cb41fefabc317f386e43e5b427d49fa16 (patch)
tree11baca40e2729cc5937d6829f6066c12c4bdd8bd /devel/p5-Event-RPC
parente3effaa594d40bc018e652053d8c1549b9598b16 (diff)
downloadports-5d31075cb41fefabc317f386e43e5b427d49fa16.tar.gz
ports-5d31075cb41fefabc317f386e43e5b427d49fa16.zip
Event::RPC supports you in developing Event based networking client/server
applications with transparent object/method access from the client to the server. Network communication is optionally encrypted using IO::Socket::SSL. Several event loop managers are supported due to an extensible API. Currently Event and Glib are implemented. WWW: http://search.cpan.org/dist/Event::RPC/ PR: ports/97350 Submitted by: Vivek Khera <vivek@khera.org>
Notes
Notes: svn path=/head/; revision=162635
Diffstat (limited to 'devel/p5-Event-RPC')
-rw-r--r--devel/p5-Event-RPC/Makefile55
-rw-r--r--devel/p5-Event-RPC/distinfo3
-rw-r--r--devel/p5-Event-RPC/pkg-descr7
-rw-r--r--devel/p5-Event-RPC/pkg-plist17
4 files changed, 82 insertions, 0 deletions
diff --git a/devel/p5-Event-RPC/Makefile b/devel/p5-Event-RPC/Makefile
new file mode 100644
index 000000000000..af72b2fdf0d3
--- /dev/null
+++ b/devel/p5-Event-RPC/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: p5-Event-RPC
+# Date created: Tue May 16 10:45:27 EDT 2006
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Event-RPC
+PORTVERSION= 0.90
+CATEGORIES= devel net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Event
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= Event based transparent Client/Server RPC framework
+
+PERL_CONFIGURE= yes
+
+MAN3= Event::RPC.3 \
+ Event::RPC::Client.3 \
+ Event::RPC::Connection.3 \
+ Event::RPC::LogConnection.3 \
+ Event::RPC::Logger.3 \
+ Event::RPC::Loop.3 \
+ Event::RPC::Loop::Event.3 \
+ Event::RPC::Loop::Glib.3 \
+ Event::RPC::Message.3 \
+ Event::RPC::Server.3
+
+OPTIONS= GLIB "Use Glib event handler" off \
+ EVENT "Use Event.pm event handler" on \
+ SSL "Register dependency to SSL lib" on
+
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+
+.if !defined(WITHOUT_EVENT)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event
+.endif
+
+.if defined(WITH_GLIB)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Glib.pm:${PORTSDIR}/devel/p5-Glib2
+.endif
+
+.if !defined(WITHOUT_SSL)
+# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+BUILD_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
+.endif
+
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Event-RPC/distinfo b/devel/p5-Event-RPC/distinfo
new file mode 100644
index 000000000000..5d915a95250b
--- /dev/null
+++ b/devel/p5-Event-RPC/distinfo
@@ -0,0 +1,3 @@
+MD5 (Event-RPC-0.90.tar.gz) = ab908f6b359e83fdd2f583a44168aa85
+SHA256 (Event-RPC-0.90.tar.gz) = cf10f54bed7e42cd5e550f0299e73fb6cc9e387d0598ffcd1e2d31fec06e7c38
+SIZE (Event-RPC-0.90.tar.gz) = 32374
diff --git a/devel/p5-Event-RPC/pkg-descr b/devel/p5-Event-RPC/pkg-descr
new file mode 100644
index 000000000000..af440c8f3432
--- /dev/null
+++ b/devel/p5-Event-RPC/pkg-descr
@@ -0,0 +1,7 @@
+Event::RPC supports you in developing Event based networking client/server
+applications with transparent object/method access from the client to the
+server. Network communication is optionally encrypted using IO::Socket::SSL.
+Several event loop managers are supported due to an extensible API. Currently
+Event and Glib are implemented.
+
+WWW: http://search.cpan.org/dist/Event::RPC/
diff --git a/devel/p5-Event-RPC/pkg-plist b/devel/p5-Event-RPC/pkg-plist
new file mode 100644
index 000000000000..498eafcc40fd
--- /dev/null
+++ b/devel/p5-Event-RPC/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/Event/RPC.pm
+%%SITE_PERL%%/Event/RPC/AuthPasswdHash.pm
+%%SITE_PERL%%/Event/RPC/Client.pm
+%%SITE_PERL%%/Event/RPC/Connection.pm
+%%SITE_PERL%%/Event/RPC/LogConnection.pm
+%%SITE_PERL%%/Event/RPC/Logger.pm
+%%SITE_PERL%%/Event/RPC/Loop.pm
+%%SITE_PERL%%/Event/RPC/Loop/Event.pm
+%%SITE_PERL%%/Event/RPC/Loop/Glib.pm
+%%SITE_PERL%%/Event/RPC/Message.pm
+%%SITE_PERL%%/Event/RPC/Server.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/RPC/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/RPC
+@dirrm %%SITE_PERL%%/Event/RPC/Loop
+@dirrm %%SITE_PERL%%/Event/RPC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Event
+@dirrmtry %%SITE_PERL%%/Event