aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-FSA-Rules
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-18 01:23:42 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-18 01:23:42 +0000
commit386578aa7c0eec72d9022b052041943d3b1f0799 (patch)
tree9542d3b4b2522c8916571e05f01970316285c6b6 /devel/p5-FSA-Rules
parent300b5df8c3647880b32a7c039fffa602e9384751 (diff)
downloadports-386578aa7c0eec72d9022b052041943d3b1f0799.tar.gz
ports-386578aa7c0eec72d9022b052041943d3b1f0799.zip
Adding port devel/p5-FSA-Rules, an implementation of Finite State Automata
Submited by: aaron Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=156246
Diffstat (limited to 'devel/p5-FSA-Rules')
-rw-r--r--devel/p5-FSA-Rules/Makefile32
-rw-r--r--devel/p5-FSA-Rules/distinfo3
-rw-r--r--devel/p5-FSA-Rules/pkg-descr19
-rw-r--r--devel/p5-FSA-Rules/pkg-plist2
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/p5-FSA-Rules/Makefile b/devel/p5-FSA-Rules/Makefile
new file mode 100644
index 000000000000..7457736d64fe
--- /dev/null
+++ b/devel/p5-FSA-Rules/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: FSA-Rules
+# Date created: 11 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= FSA-Rules
+PORTVERSION= 0.23
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/D/DW/DWHEELER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Build simple rules-based state machines in Perl
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone \
+ ${SITE_PERL}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= FSA::Rules.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6 due to dependencies
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-FSA-Rules/distinfo b/devel/p5-FSA-Rules/distinfo
new file mode 100644
index 000000000000..24bbb3f526c4
--- /dev/null
+++ b/devel/p5-FSA-Rules/distinfo
@@ -0,0 +1,3 @@
+MD5 (FSA-Rules-0.23.tar.gz) = 34521dec9ec1acba34617a48a0a8f332
+SHA256 (FSA-Rules-0.23.tar.gz) = 59a8cd7f59ad0ca3f8b5482160890f4ccfcc974c7ff89ce26be630d118985b1c
+SIZE (FSA-Rules-0.23.tar.gz) = 27690
diff --git a/devel/p5-FSA-Rules/pkg-descr b/devel/p5-FSA-Rules/pkg-descr
new file mode 100644
index 000000000000..91dbab4e0b26
--- /dev/null
+++ b/devel/p5-FSA-Rules/pkg-descr
@@ -0,0 +1,19 @@
+This class implements a simple state machine pattern, allowing you to
+quickly build rules-based state machines in Perl. As a simple
+implementation of a powerful concept, it differs slightly from an ideal
+DFA model in that it does not enforce a single possible switch from one
+state to another. Rather, it short circuits the evaluation of the rules
+for such switches, so that the first rule to return a true value will
+trigger its switch and no other switch rules will be checked. (But see the
+strict attribute and parameter to new().) It differs from an NFA model in
+that it offers no back-tracking. But in truth, you can use it to build a
+state machine that adheres to either model--hence the more generic FSA
+moniker.
+
+WWW: http://search.cpan.org/dist/FSA-Rules
+Authors: David Wheeler <david@kineticode.com>
+Curtis "Ovid" Poe <eop_divo_sitruc@yahoo.com> (reverse the name to email him)
+
+--
+Aaron Dalton
+aaron@FreeBSD.org
diff --git a/devel/p5-FSA-Rules/pkg-plist b/devel/p5-FSA-Rules/pkg-plist
new file mode 100644
index 000000000000..b57efc7fd6b6
--- /dev/null
+++ b/devel/p5-FSA-Rules/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/FSA/Rules.pm
+@dirrm %%SITE_PERL%%/FSA