aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Slurp
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-03-01 06:39:18 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-03-01 06:39:18 +0000
commit68c2f99c6300bc38a37eb3a8292b562cc2d8952b (patch)
tree0898749bb767b388765958548da12c5b50b3825d /devel/p5-File-Slurp
parent031bd55ed2b892d722ffdba72b339be33879e047 (diff)
downloadports-68c2f99c6300bc38a37eb3a8292b562cc2d8952b.tar.gz
ports-68c2f99c6300bc38a37eb3a8292b562cc2d8952b.zip
Remove do-configure section, use PERL_CONFIGURE now.
Notes
Notes: svn path=/head/; revision=38917
Diffstat (limited to 'devel/p5-File-Slurp')
-rw-r--r--devel/p5-File-Slurp/Makefile5
-rw-r--r--devel/p5-File-Slurp/pkg-descr42
2 files changed, 22 insertions, 25 deletions
diff --git a/devel/p5-File-Slurp/Makefile b/devel/p5-File-Slurp/Makefile
index 71511a51bb0d..426446f74070 100644
--- a/devel/p5-File-Slurp/Makefile
+++ b/devel/p5-File-Slurp/Makefile
@@ -14,12 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
-USE_PERL5= YES
+PERL_CONFIGURE= YES
MAN3= File::Slurp.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/devel/p5-File-Slurp/pkg-descr b/devel/p5-File-Slurp/pkg-descr
index 789296403703..c84a40630d8d 100644
--- a/devel/p5-File-Slurp/pkg-descr
+++ b/devel/p5-File-Slurp/pkg-descr
@@ -1,28 +1,28 @@
- These are quickie routines that are meant to save a couple
- of lines of code over and over again. They do not do
- anything fancy.
+These are quickie routines that are meant to save a couple
+of lines of code over and over again. They do not do
+anything fancy.
- read_file() does what you would expect. If you are using
- its output in array context, then it returns an array of
- lines. If you are calling it from scalar context, then
- returns the entire file in a single string.
+read_file() does what you would expect. If you are using
+its output in array context, then it returns an array of
+lines. If you are calling it from scalar context, then
+returns the entire file in a single string.
- It croaks()s if it can't open the file.
+It croaks()s if it can't open the file.
- write_file() creates or overwrites files.
+write_file() creates or overwrites files.
- append_file() appends to a file.
+append_file() appends to a file.
- overwrite_file() does an in-place update of an existing
- file or creates a new file if it didn't already exist.
+overwrite_file() does an in-place update of an existing
+file or creates a new file if it didn't already exist.
- Write_file will also replace a file. The difference is
- that the first that that write_file() does is to trucate
- the file whereas the last thing that overwrite_file() is
- to trucate the file. Overwrite_file() should be used in
- situations where you have a file that always needs to have
- contents, even in the middle of an update.
+Write_file will also replace a file. The difference is
+that the first that that write_file() does is to trucate
+the file whereas the last thing that overwrite_file() is
+to trucate the file. Overwrite_file() should be used in
+situations where you have a file that always needs to have
+contents, even in the middle of an update.
- read_dir() returns all of the entries in a directory
- except for "." and "..". It croaks if it cannot open the
- directory.
+read_dir() returns all of the entries in a directory
+except for "." and "..". It croaks if it cannot open the
+directory.