aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Stream
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-06 13:35:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-06 13:35:03 +0000
commit1cd66a015e1454e48421b1d38aa5385ee9440e60 (patch)
treee3857893b22966f0b5a8d05d15e0f55f88aa9a32 /devel/p5-File-Stream
parent5c6566d9064d851df77e04377e3c9e1a35a34fc9 (diff)
downloadports-1cd66a015e1454e48421b1d38aa5385ee9440e60.tar.gz
ports-1cd66a015e1454e48421b1d38aa5385ee9440e60.zip
Perl filehandles are streams, but sometimes they just aren't powerful
enough. This module offers to have streams from filehandles searched with regexes and allows the global input record separator variable to contain regexes. Thus, readline() and the <> operator can now return records delimited by regular expression matches. WWW: http://search.cpan.org/dist/File-Stream/ PR: ports/125926 Submitted by: Tomoyuki Sakurai <cherry at trombik.org>
Notes
Notes: svn path=/head/; revision=218135
Diffstat (limited to 'devel/p5-File-Stream')
-rw-r--r--devel/p5-File-Stream/Makefile22
-rw-r--r--devel/p5-File-Stream/distinfo3
-rw-r--r--devel/p5-File-Stream/pkg-descr9
-rw-r--r--devel/p5-File-Stream/pkg-plist2
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/p5-File-Stream/Makefile b/devel/p5-File-Stream/Makefile
new file mode 100644
index 000000000000..1b60b07da61f
--- /dev/null
+++ b/devel/p5-File-Stream/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-File-Stream
+# Date created: 2008-07-21
+# Whom: Tomoyuki Sakurai <cherry@trombik.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Stream
+PORTVERSION= 2.20
+CATEGORIES= devel
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cherry@trombik.org
+COMMENT= Regular expression delimited records from streams
+
+RUN_DEPENDS= p5-YAPE-Regex>=3.02:${PORTSDIR}/textproc/p5-YAPE-Regex
+
+MAN3= File::Stream.3
+PERL_MODBUILD= Yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Stream/distinfo b/devel/p5-File-Stream/distinfo
new file mode 100644
index 000000000000..91a636e5223a
--- /dev/null
+++ b/devel/p5-File-Stream/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Stream-2.20.tar.gz) = 66704b4b0b9d42f962b5d6ab55ec1418
+SHA256 (File-Stream-2.20.tar.gz) = db43c2154b5e449166a7e34dd647f53891898cff7f7e15ed59f8df512fc20a21
+SIZE (File-Stream-2.20.tar.gz) = 6720
diff --git a/devel/p5-File-Stream/pkg-descr b/devel/p5-File-Stream/pkg-descr
new file mode 100644
index 000000000000..8d685e3a68bf
--- /dev/null
+++ b/devel/p5-File-Stream/pkg-descr
@@ -0,0 +1,9 @@
+Perl filehandles are streams, but sometimes they just aren't powerful
+enough. This module offers to have streams from filehandles searched with
+regexes and allows the global input record separator variable to contain
+regexes.
+
+Thus, readline() and the <> operator can now return records delimited by
+regular expression matches.
+
+WWW: http://search.cpan.org/dist/File-Stream/
diff --git a/devel/p5-File-Stream/pkg-plist b/devel/p5-File-Stream/pkg-plist
new file mode 100644
index 000000000000..a963f77d7da0
--- /dev/null
+++ b/devel/p5-File-Stream/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/File/Stream.pm
+@dirrmtry %%SITE_PERL%%/File