aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Heap-Simple
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-26 16:29:55 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-26 16:29:55 +0000
commit128166aa91973affad0a9504a66cf31fa0bc9d7d (patch)
tree97c036b36d358eb52fe9d2ccd9304ac6bad8c26e /devel/p5-Heap-Simple
parent23938a512f739f2cd7715984b8ec4d3bc27414e0 (diff)
downloadports-128166aa91973affad0a9504a66cf31fa0bc9d7d.tar.gz
ports-128166aa91973affad0a9504a66cf31fa0bc9d7d.zip
Add p5-Heap-Simple 0.05, fast and easy to use classic heaps.
PR: ports/70995 Submitted by: Aaron Dalton <aaron@daltons.ca>
Notes
Notes: svn path=/head/; revision=117318
Diffstat (limited to 'devel/p5-Heap-Simple')
-rw-r--r--devel/p5-Heap-Simple/Makefile28
-rw-r--r--devel/p5-Heap-Simple/distinfo2
-rw-r--r--devel/p5-Heap-Simple/pkg-descr24
-rw-r--r--devel/p5-Heap-Simple/pkg-plist33
4 files changed, 87 insertions, 0 deletions
diff --git a/devel/p5-Heap-Simple/Makefile b/devel/p5-Heap-Simple/Makefile
new file mode 100644
index 000000000000..05b5d7c1c5b0
--- /dev/null
+++ b/devel/p5-Heap-Simple/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Heap::Simple
+# Date created: 26 August 2004
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Heap-Simple
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Heap
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Fast and easy to use classic heaps
+
+PERL_CONFIGURE= yes
+
+MAN3= Heap::Simple.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Uses ??{} in regexps, which came with perl5.6, install lang/perl5 or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Heap-Simple/distinfo b/devel/p5-Heap-Simple/distinfo
new file mode 100644
index 000000000000..b4a44e5b2da0
--- /dev/null
+++ b/devel/p5-Heap-Simple/distinfo
@@ -0,0 +1,2 @@
+MD5 (Heap-Simple-0.05.tar.gz) = 7c39f3fcebeaa8679e75acad5e6bc47f
+SIZE (Heap-Simple-0.05.tar.gz) = 15186
diff --git a/devel/p5-Heap-Simple/pkg-descr b/devel/p5-Heap-Simple/pkg-descr
new file mode 100644
index 000000000000..93bc6109d2fd
--- /dev/null
+++ b/devel/p5-Heap-Simple/pkg-descr
@@ -0,0 +1,24 @@
+A heap is a partially sorted structure where it's always easy to extract the
+smallest element. If the collection of elements is changing dynamically, a
+heap has less overhead than keeping the collection fully sorted.
+
+The order in which equal elements get extracted is unspecified.
+
+The main order relations supported by this module are "<" (numeric compare)
+and "lt" (string compare).
+
+The module allows you to manage data where the elements are of several
+allowed types, in particular array references, hash references, objects or
+just the keys themselves.
+
+The internals of the module do nothing with the elements inserted except
+inspecting the key. This means that if you for example store a blessed object,
+that's what you will get back on extract. It's also ok to keep references to
+the elements around and make changes to them while they are in the heap as
+long as you don't change the key.
+
+WWW: http://search.cpan.org/dist/Heap-Simple/
+Author: Ton Hospel <Heap::Simple@home.lunix>
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/devel/p5-Heap-Simple/pkg-plist b/devel/p5-Heap-Simple/pkg-plist
new file mode 100644
index 000000000000..fdf9f1792bb5
--- /dev/null
+++ b/devel/p5-Heap-Simple/pkg-plist
@@ -0,0 +1,33 @@
+%%SITE_PERL%%/Heap/Simple.pm
+%%SITE_PERL%%/Heap/Simple/Any.pm
+%%SITE_PERL%%/Heap/Simple/Array.pm
+%%SITE_PERL%%/Heap/Simple/Function.pm
+%%SITE_PERL%%/Heap/Simple/Hash.pm
+%%SITE_PERL%%/Heap/Simple/Key.pm
+%%SITE_PERL%%/Heap/Simple/Less.pm
+%%SITE_PERL%%/Heap/Simple/Method.pm
+%%SITE_PERL%%/Heap/Simple/Number.pm
+%%SITE_PERL%%/Heap/Simple/NumberReverse.pm
+%%SITE_PERL%%/Heap/Simple/Object.pm
+%%SITE_PERL%%/Heap/Simple/String.pm
+%%SITE_PERL%%/Heap/Simple/StringReverse.pm
+%%SITE_PERL%%/Heap/Simple/Wrapper.pm
+%%SITE_PERL%%/auto/Heap/Simple/autosplit.ix
+%%SITE_PERL%%/auto/Heap/Simple/extract_min.al
+%%SITE_PERL%%/auto/Heap/Simple/extract_upto.al
+%%SITE_PERL%%/auto/Heap/Simple/first.al
+%%SITE_PERL%%/auto/Heap/Simple/first_key.al
+%%SITE_PERL%%/auto/Heap/Simple/infinity.al
+%%SITE_PERL%%/auto/Heap/Simple/insert.al
+%%SITE_PERL%%/auto/Heap/Simple/key.al
+%%SITE_PERL%%/auto/Heap/Simple/keys.al
+%%SITE_PERL%%/auto/Heap/Simple/min_key.al
+%%SITE_PERL%%/auto/Heap/Simple/user_data.al
+%%SITE_PERL%%/auto/Heap/Simple/values.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap 2>/dev/null || true
+@dirrm %%SITE_PERL%%/auto/Heap/Simple
+@unexec rmdir %D/%%SITE_PERL%%/auto/Heap 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Heap/Simple
+@unexec rmdir %D/%%SITE_PERL%%/Heap 2>/dev/null || true