aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Hook-LexWrap
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-07-07 14:24:49 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-07-07 14:24:49 +0000
commit6687a7a5c2c23804135578a434ae1394832722c9 (patch)
tree09c943f0886e3163174280d130ce0d68d8cf3bb2 /devel/p5-Hook-LexWrap
parent28cb1cffceda7b0a4111f80cf78eca3476e036e9 (diff)
downloadports-6687a7a5c2c23804135578a434ae1394832722c9.tar.gz
ports-6687a7a5c2c23804135578a434ae1394832722c9.zip
Add devel/p5-Hook-LexWrap, a module implementing lexically scoped
subroutine wrappers for Perl.
Notes
Notes: svn path=/head/; revision=113145
Diffstat (limited to 'devel/p5-Hook-LexWrap')
-rw-r--r--devel/p5-Hook-LexWrap/Makefile28
-rw-r--r--devel/p5-Hook-LexWrap/distinfo2
-rw-r--r--devel/p5-Hook-LexWrap/pkg-descr4
-rw-r--r--devel/p5-Hook-LexWrap/pkg-plist6
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-Hook-LexWrap/Makefile b/devel/p5-Hook-LexWrap/Makefile
new file mode 100644
index 000000000000..6632ff74cf67
--- /dev/null
+++ b/devel/p5-Hook-LexWrap/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Hook-LexWrap
+# Date created: Wed Jul 7 2004
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Hook-LexWrap
+PORTVERSION= 0.20
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Hook
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Lexically scoped subroutine wrappers for Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Hook::LexWrap.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port only support perl 5.6.1 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Hook-LexWrap/distinfo b/devel/p5-Hook-LexWrap/distinfo
new file mode 100644
index 000000000000..29ed1e1d2bde
--- /dev/null
+++ b/devel/p5-Hook-LexWrap/distinfo
@@ -0,0 +1,2 @@
+MD5 (Hook-LexWrap-0.20.tar.gz) = e3aaeb59a3adddc80ed3867e4d16654e
+SIZE (Hook-LexWrap-0.20.tar.gz) = 6369
diff --git a/devel/p5-Hook-LexWrap/pkg-descr b/devel/p5-Hook-LexWrap/pkg-descr
new file mode 100644
index 000000000000..bbb470c9814a
--- /dev/null
+++ b/devel/p5-Hook-LexWrap/pkg-descr
@@ -0,0 +1,4 @@
+Hook::LexWrap allows you to install a pre- or post-wrapper (or both)
+around an existing subroutine.
+
+WWW: http://search.cpan.org/dist/Hook-LexWrap/
diff --git a/devel/p5-Hook-LexWrap/pkg-plist b/devel/p5-Hook-LexWrap/pkg-plist
new file mode 100644
index 000000000000..b29379103b5b
--- /dev/null
+++ b/devel/p5-Hook-LexWrap/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hook/LexWrap/.packlist
+%%SITE_PERL%%/Hook/LexWrap.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Hook/LexWrap
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hook 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Hook 2>/dev/null || true