aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IPC-Cmd
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-09-21 11:28:02 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-09-21 11:28:02 +0000
commite689d7ec6500ee72bb14546d30ab67c12627b3c5 (patch)
tree7e029874f44cd460ca5f1aec58edc86156e97306 /devel/p5-IPC-Cmd
parent24c23be75da94223d745e9ba05a4b671c11b83a8 (diff)
downloadports-e689d7ec6500ee72bb14546d30ab67c12627b3c5.tar.gz
ports-e689d7ec6500ee72bb14546d30ab67c12627b3c5.zip
Update to 0.25. Also make work with older perls (not part of the PR).
PR: 102952 Submitted by: gslin@gslin.org
Notes
Notes: svn path=/head/; revision=173529
Diffstat (limited to 'devel/p5-IPC-Cmd')
-rw-r--r--devel/p5-IPC-Cmd/Makefile9
-rw-r--r--devel/p5-IPC-Cmd/distinfo6
-rw-r--r--devel/p5-IPC-Cmd/files/patch-IPC-Cmd.pm21
3 files changed, 30 insertions, 6 deletions
diff --git a/devel/p5-IPC-Cmd/Makefile b/devel/p5-IPC-Cmd/Makefile
index 3bd562215c9f..42855398b00a 100644
--- a/devel/p5-IPC-Cmd/Makefile
+++ b/devel/p5-IPC-Cmd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= IPC-Cmd
-PORTVERSION= 0.24
+PORTVERSION= 0.25
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= IPC
@@ -15,14 +15,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= IPC::Cmd - finding and running system commands made easy
-BUILD_DEPENDS= ${SITE_PERL}/Locale/Maketext/Simple.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
+RUN_DEPENDS= ${SITE_PERL}/Locale/Maketext/Simple.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
${SITE_PERL}/Module/Load/Conditional.pm:${PORTSDIR}/devel/p5-Module-Load-Conditional \
${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
${SITE_PERL}/Params/Check.pm:${PORTSDIR}/devel/p5-Params-Check
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN3= IPC::Cmd.3
+post-patch:
+ ${RM} -f ${WRKSRC}/lib/IPC/Cmd.pm.orig
+
.include <bsd.port.mk>
diff --git a/devel/p5-IPC-Cmd/distinfo b/devel/p5-IPC-Cmd/distinfo
index da819ec60e28..342c83f0e9b1 100644
--- a/devel/p5-IPC-Cmd/distinfo
+++ b/devel/p5-IPC-Cmd/distinfo
@@ -1,3 +1,3 @@
-MD5 (IPC-Cmd-0.24.tar.gz) = 9061bd187defad873432f91fa6de9f9b
-SHA256 (IPC-Cmd-0.24.tar.gz) = c2227c2b07c00eb44b268c11beeff9361b4ff84828b6e9c601c8736a264f3ecc
-SIZE (IPC-Cmd-0.24.tar.gz) = 8158
+MD5 (IPC-Cmd-0.25.tar.gz) = 69bb014822594266ca2cbd01aae54912
+SHA256 (IPC-Cmd-0.25.tar.gz) = a5dc8190cfd34ee55e5979eb501d04239470e73fdf2699b19f34640ec5056778
+SIZE (IPC-Cmd-0.25.tar.gz) = 9969
diff --git a/devel/p5-IPC-Cmd/files/patch-IPC-Cmd.pm b/devel/p5-IPC-Cmd/files/patch-IPC-Cmd.pm
new file mode 100644
index 000000000000..1befaa9dec3f
--- /dev/null
+++ b/devel/p5-IPC-Cmd/files/patch-IPC-Cmd.pm
@@ -0,0 +1,21 @@
+--- lib/IPC/Cmd.pm Wed Sep 6 17:34:32 2006
++++ lib/IPC/Cmd.pm Thu Sep 21 13:15:15 2006
+@@ -260,8 +260,7 @@ sub _open3_run {
+ ### child process. This stops us from having to pump input
+ ### from ourselves to the childprocess. However, we will need
+ ### to revive the FH afterwards, as IPC::Open3 closes it.
+- my $save_stdin;
+- open $save_stdin, "<&STDIN" or (
++ open IPC_CMD_SAVE_STDIN, "<&STDIN" or (
+ warn(loc("Could not dup STDIN: %1",$!)),
+ return
+ );
+@@ -317,7 +316,7 @@ sub _open3_run {
+
+ ### restore STDIN after duping, or STDIN will be closed for
+ ### this current perl process!
+- open STDIN, "<&", $save_stdin or (
++ open STDIN, "<& IPC_CMD_SAVE_STDIN" or (
+ warn(loc("Could not restore STDIN: %1", $!)),
+ return
+ );