aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IPC-Run
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-07-12 22:16:42 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-07-12 22:16:42 +0000
commit9cce736c9b7b0cd6ccc98b724a63f75b15278cbd (patch)
tree11790fead34779759bdaafb56e3d2b0fe8ba8d6e /devel/p5-IPC-Run
parent62cc92f957a4f6ccb93cc43dc3177681af56a5e3 (diff)
downloadports-9cce736c9b7b0cd6ccc98b724a63f75b15278cbd.tar.gz
ports-9cce736c9b7b0cd6ccc98b724a63f75b15278cbd.zip
Add p5-IPC-Run - a perl module to run subprocesses with piping and
redirection.
Notes
Notes: svn path=/head/; revision=45086
Diffstat (limited to 'devel/p5-IPC-Run')
-rw-r--r--devel/p5-IPC-Run/Makefile25
-rw-r--r--devel/p5-IPC-Run/distinfo1
-rw-r--r--devel/p5-IPC-Run/pkg-comment1
-rw-r--r--devel/p5-IPC-Run/pkg-descr6
-rw-r--r--devel/p5-IPC-Run/pkg-plist8
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/p5-IPC-Run/Makefile b/devel/p5-IPC-Run/Makefile
new file mode 100644
index 000000000000..0c214653fb81
--- /dev/null
+++ b/devel/p5-IPC-Run/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devele/p5-IPC-Run
+# Date created: 12 July 2001
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IPC-Run
+PORTVERSION= 0.44
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IPC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= IPC::Run.3 IPC::Run::IO.3 IPC::Run::Timer.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IPC-Run/distinfo b/devel/p5-IPC-Run/distinfo
new file mode 100644
index 000000000000..f1185e96bc14
--- /dev/null
+++ b/devel/p5-IPC-Run/distinfo
@@ -0,0 +1 @@
+MD5 (IPC-Run-0.44.tar.gz) = 3a00ba86476673974079f69a773d3d06
diff --git a/devel/p5-IPC-Run/pkg-comment b/devel/p5-IPC-Run/pkg-comment
new file mode 100644
index 000000000000..e0a9f5ec5ebf
--- /dev/null
+++ b/devel/p5-IPC-Run/pkg-comment
@@ -0,0 +1 @@
+IPC::Run - Run subprocesses with piping and redirection
diff --git a/devel/p5-IPC-Run/pkg-descr b/devel/p5-IPC-Run/pkg-descr
new file mode 100644
index 000000000000..0c9737bf8a71
--- /dev/null
+++ b/devel/p5-IPC-Run/pkg-descr
@@ -0,0 +1,6 @@
+IPC::Run allows you run and interact with child processes, files, pipes,
+and pseudo-ttys. Both event-loop and procedural techniques are
+supported and may be mixed. Likewise, functional and OO API styles are
+both supported and may be mixed.
+
+Currently, pseudo-ttys operations are not supported in FreeBSD.
diff --git a/devel/p5-IPC-Run/pkg-plist b/devel/p5-IPC-Run/pkg-plist
new file mode 100644
index 000000000000..f1459b4ea153
--- /dev/null
+++ b/devel/p5-IPC-Run/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/Run/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/IPC/Run.pm
+lib/perl5/site_perl/%%PERL_VER%%/IPC/Run/Timer.pm
+lib/perl5/site_perl/%%PERL_VER%%/IPC/Run/IO.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/Run
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/IPC/Run
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/IPC 2>/dev/null || true