aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IPC-ShareLite
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-04-02 22:10:05 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-04-02 22:10:05 +0000
commit9473b21b8b799b68c6c3e0303586c0f96197f48a (patch)
tree30a385a09dbabd2bcd85443c499fef7602f9fcbb /devel/p5-IPC-ShareLite
parent33017dbf5bde05d7931b6cc5c079e36e7aae2a34 (diff)
downloadports-9473b21b8b799b68c6c3e0303586c0f96197f48a.tar.gz
ports-9473b21b8b799b68c6c3e0303586c0f96197f48a.zip
p5-IPC-ShareLite is a simple interface to acess shared mem.
Notes
Notes: svn path=/head/; revision=40774
Diffstat (limited to 'devel/p5-IPC-ShareLite')
-rw-r--r--devel/p5-IPC-ShareLite/Makefile22
-rw-r--r--devel/p5-IPC-ShareLite/distinfo1
-rw-r--r--devel/p5-IPC-ShareLite/files/patch-Configure38
-rw-r--r--devel/p5-IPC-ShareLite/files/patch-Makefile.PL10
-rw-r--r--devel/p5-IPC-ShareLite/pkg-comment1
-rw-r--r--devel/p5-IPC-ShareLite/pkg-descr4
-rw-r--r--devel/p5-IPC-ShareLite/pkg-plist6
7 files changed, 82 insertions, 0 deletions
diff --git a/devel/p5-IPC-ShareLite/Makefile b/devel/p5-IPC-ShareLite/Makefile
new file mode 100644
index 000000000000..d4c65bff32a4
--- /dev/null
+++ b/devel/p5-IPC-ShareLite/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-IPC-ShareLite
+# Date created: April 03 2001
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= IPC-ShareLite
+PORTVERSION= 0.08
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IPC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= IPC::ShareLite.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IPC-ShareLite/distinfo b/devel/p5-IPC-ShareLite/distinfo
new file mode 100644
index 000000000000..3f2dd47386d9
--- /dev/null
+++ b/devel/p5-IPC-ShareLite/distinfo
@@ -0,0 +1 @@
+MD5 (IPC-ShareLite-0.08.tar.gz) = 2c908d8b733faa0426acb513e5319bf7
diff --git a/devel/p5-IPC-ShareLite/files/patch-Configure b/devel/p5-IPC-ShareLite/files/patch-Configure
new file mode 100644
index 000000000000..6152d82c340f
--- /dev/null
+++ b/devel/p5-IPC-ShareLite/files/patch-Configure
@@ -0,0 +1,38 @@
+--- Configure.orig Tue Apr 3 04:46:13 2001
++++ Configure Tue Apr 3 04:50:15 2001
+@@ -3042,35 +3042,6 @@
+ : preserve RCS keywords in files with variable substitution, grrr
+ Id='$Id'
+
+-: Finish up by extracting the .SH files
+-case "$alldone" in
+-exit)
+- $rm -rf UU
+- echo "Done."
+- exit 0
+- ;;
+-cont)
+- ;;
+-'')
+- dflt=''
+- nostick=true
+- $cat <<EOM
+-
+-If you'd like to make any changes to the config.sh file before I begin
+-to configure things, do it as a shell escape now (e.g. !vi config.sh).
+-
+-EOM
+- rp="Press return or use a shell escape to edit config.sh:"
+- . UU/myread
+- nostick=''
+- case "$ans" in
+- '') ;;
+- *) : in case they cannot read
+- sh 1>&4 -c "$ans";;
+- esac
+- ;;
+-esac
+-
+ : if this fails, just run all the .SH files by hand
+ . ./config.sh
+
diff --git a/devel/p5-IPC-ShareLite/files/patch-Makefile.PL b/devel/p5-IPC-ShareLite/files/patch-Makefile.PL
new file mode 100644
index 000000000000..aaec7d9eea36
--- /dev/null
+++ b/devel/p5-IPC-ShareLite/files/patch-Makefile.PL
@@ -0,0 +1,10 @@
+--- Makefile.PL.orig Tue Apr 3 04:45:01 2001
++++ Makefile.PL Tue Apr 3 04:45:07 2001
+@@ -1,6 +1,6 @@
+ use ExtUtils::MakeMaker;
+
+-system('./Configure');
++system('./Configure -d');
+
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.
diff --git a/devel/p5-IPC-ShareLite/pkg-comment b/devel/p5-IPC-ShareLite/pkg-comment
new file mode 100644
index 000000000000..57617be0af68
--- /dev/null
+++ b/devel/p5-IPC-ShareLite/pkg-comment
@@ -0,0 +1 @@
+A simple interface to access shared memory
diff --git a/devel/p5-IPC-ShareLite/pkg-descr b/devel/p5-IPC-ShareLite/pkg-descr
new file mode 100644
index 000000000000..f99ac623e59f
--- /dev/null
+++ b/devel/p5-IPC-ShareLite/pkg-descr
@@ -0,0 +1,4 @@
+PC::ShareLite provides a simple interface to shared memory, allowing
+data to be efficiently communicated between processes. Your operating
+system must support SysV IPC (shared memory and semaphores) in order to
+use this module.
diff --git a/devel/p5-IPC-ShareLite/pkg-plist b/devel/p5-IPC-ShareLite/pkg-plist
new file mode 100644
index 000000000000..83b4de930d83
--- /dev/null
+++ b/devel/p5-IPC-ShareLite/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/IPC/ShareLite.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/ShareLite/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/ShareLite/ShareLite.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/ShareLite/ShareLite.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/ShareLite/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/ShareLite