aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Inline/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-15 09:55:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-15 09:55:31 +0000
commit69eca71474edc536d9283ab825d053f522e9d7de (patch)
tree621cab4c45f8b5c6f8a4a8888133557a9535d7a3 /devel/p5-Inline/Makefile
parentc7b7aaf0d8ea2099a4fea2cc540867035a4bd282 (diff)
downloadports-69eca71474edc536d9283ab825d053f522e9d7de.tar.gz
ports-69eca71474edc536d9283ab825d053f522e9d7de.zip
add p5-Inline
Write Perl subroutines in other programming languages PR: 32833 Submitted by: Sergey Skvortsov <skv@protey.ru>
Notes
Notes: svn path=/head/; revision=51556
Diffstat (limited to 'devel/p5-Inline/Makefile')
-rw-r--r--devel/p5-Inline/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/p5-Inline/Makefile b/devel/p5-Inline/Makefile
new file mode 100644
index 000000000000..efc80d864437
--- /dev/null
+++ b/devel/p5-Inline/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Inline
+# Date created: 14 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Inline
+PORTVERSION= 0.43
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Inline
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PATCH_STRIP= -p1
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Inline-API.3 Inline-FAQ.3 Inline-Support.3 Inline.3 \
+ Inline::C-Cookbook.3 Inline::C.3
+
+.include <bsd.port.mk>