aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Iterator-Misc
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-18 22:10:14 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-18 22:10:14 +0000
commit717f8f709dc2c2e1d94d5a79f648f72e78a01370 (patch)
tree61d73611fea7222af41e8c4f3a4e3e0718d522b9 /devel/p5-Iterator-Misc
parent3b74952bad10de06f3b9bf79e3fe7c1444c3793a (diff)
downloadports-717f8f709dc2c2e1d94d5a79f648f72e78a01370.tar.gz
ports-717f8f709dc2c2e1d94d5a79f648f72e78a01370.zip
Adding port devel/p5-Iterator-Misc, Miscellaneous iterator functions.
Committed by: aaron Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=156334
Diffstat (limited to 'devel/p5-Iterator-Misc')
-rw-r--r--devel/p5-Iterator-Misc/Makefile31
-rw-r--r--devel/p5-Iterator-Misc/distinfo3
-rw-r--r--devel/p5-Iterator-Misc/pkg-descr9
-rw-r--r--devel/p5-Iterator-Misc/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/p5-Iterator-Misc/Makefile b/devel/p5-Iterator-Misc/Makefile
new file mode 100644
index 000000000000..7df65ba63070
--- /dev/null
+++ b/devel/p5-Iterator-Misc/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Iterator-Misc
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Iterator-Misc
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Iterator
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Miscellaneous iterator functions
+
+BUILD_DEPENDS= ${SITE_PERL}/Iterator.pm:${PORTSDIR}/devel/p5-Iterator
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= Iterator::Misc.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl5.8 due to dependencies
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Iterator-Misc/distinfo b/devel/p5-Iterator-Misc/distinfo
new file mode 100644
index 000000000000..675025da6ee6
--- /dev/null
+++ b/devel/p5-Iterator-Misc/distinfo
@@ -0,0 +1,3 @@
+MD5 (Iterator-Misc-0.03.tar.gz) = 9c2a1fe167ddafb10352d5b0518c6970
+SHA256 (Iterator-Misc-0.03.tar.gz) = ec90b3fc508886a5d863ddb5079930597f5143207aa1500b5c8b400cb17c3180
+SIZE (Iterator-Misc-0.03.tar.gz) = 12323
diff --git a/devel/p5-Iterator-Misc/pkg-descr b/devel/p5-Iterator-Misc/pkg-descr
new file mode 100644
index 000000000000..862a9207ae47
--- /dev/null
+++ b/devel/p5-Iterator-Misc/pkg-descr
@@ -0,0 +1,9 @@
+This module contains miscellaneous iterator utility functions that I think
+aren't as broadly useful as the ones in Iterator::Util. They are here to
+keep the size of Iterator::Util down.
+
+For more information on iterators and how to use them, see the Iterator
+module documentation.
+
+WWW: http://search.cpan.org/dist/Iterator-DBI
+Author: Eric J. Roode <roode@cpan.org>
diff --git a/devel/p5-Iterator-Misc/pkg-plist b/devel/p5-Iterator-Misc/pkg-plist
new file mode 100644
index 000000000000..e200c100c69a
--- /dev/null
+++ b/devel/p5-Iterator-Misc/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Iterator/Misc.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Iterator/Misc/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Iterator/Misc
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Iterator
+@dirrmtry %%SITE_PERL%%/Iterator