aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-JIRA-Client
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2009-04-29 14:01:25 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2009-04-29 14:01:25 +0000
commitb2c63956fdacb3486b9f6ee9582b410cdcd468df (patch)
tree21e53f2844a696dd599209259cec8c473bb0be8a /devel/p5-JIRA-Client
parentb4439e98242688dee6c01e76a1e5575c18d0e7ab (diff)
downloadports-b2c63956fdacb3486b9f6ee9582b410cdcd468df.tar.gz
ports-b2c63956fdacb3486b9f6ee9582b410cdcd468df.zip
JIRA is a proprietary bug tracking system from Atlassian
(http://www.atlassian.com/software/jira/). This module implements an Object Oriented wrapper around JIRA's SOAP API, which is specified in: http://preview.tinyurl.com/JiraSoapServiceApi Moreover, it implements some other methods to make it easier to do some common operations. WWW: http://search.cpan.org/dist/JIRA-Client/
Notes
Notes: svn path=/head/; revision=232946
Diffstat (limited to 'devel/p5-JIRA-Client')
-rw-r--r--devel/p5-JIRA-Client/Makefile27
-rw-r--r--devel/p5-JIRA-Client/distinfo3
-rw-r--r--devel/p5-JIRA-Client/pkg-descr11
-rw-r--r--devel/p5-JIRA-Client/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/p5-JIRA-Client/Makefile b/devel/p5-JIRA-Client/Makefile
new file mode 100644
index 000000000000..4d1dd697195a
--- /dev/null
+++ b/devel/p5-JIRA-Client/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: JIRA::Client
+# Date created: 2009-04-28
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JIRA-Client
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ LOCAL/glarkin
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= An extended interface to JIRA's SOAP API
+
+RUN_DEPENDS= p5-IO>=0:${PORTSDIR}/devel/p5-IO \
+ p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+PROJECTHOST= jira-client
+
+MAN3= JIRA::Client.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-JIRA-Client/distinfo b/devel/p5-JIRA-Client/distinfo
new file mode 100644
index 000000000000..8a92e2e529b1
--- /dev/null
+++ b/devel/p5-JIRA-Client/distinfo
@@ -0,0 +1,3 @@
+MD5 (JIRA-Client-0.03.tar.gz) = 94c60f6991444cd63fb4c5532411b1eb
+SHA256 (JIRA-Client-0.03.tar.gz) = 6217803da6aaa294e2f2627a0d19cae923f99ceceeaaee643bf8e24914600bce
+SIZE (JIRA-Client-0.03.tar.gz) = 5580
diff --git a/devel/p5-JIRA-Client/pkg-descr b/devel/p5-JIRA-Client/pkg-descr
new file mode 100644
index 000000000000..009225e8b4a1
--- /dev/null
+++ b/devel/p5-JIRA-Client/pkg-descr
@@ -0,0 +1,11 @@
+JIRA is a proprietary bug tracking system from Atlassian
+(http://www.atlassian.com/software/jira/).
+
+This module implements an Object Oriented wrapper around JIRA's
+SOAP API, which is specified in:
+http://preview.tinyurl.com/JiraSoapServiceApi
+
+Moreover, it implements some other methods to make it easier to do
+some common operations.
+
+WWW: http://search.cpan.org/dist/JIRA-Client/
diff --git a/devel/p5-JIRA-Client/pkg-plist b/devel/p5-JIRA-Client/pkg-plist
new file mode 100644
index 000000000000..1de380175055
--- /dev/null
+++ b/devel/p5-JIRA-Client/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/JIRA/Client.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JIRA/Client/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JIRA/Client
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JIRA
+@dirrm %%SITE_PERL%%/JIRA