aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-JSON-RPC-Dispatcher
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-04-21 01:02:14 +0000
committerWen Heping <wen@FreeBSD.org>2010-04-21 01:02:14 +0000
commit694ede403d1791a6e9a4bb964917c55ccda73a37 (patch)
tree7652b388c56c6684f7ebbc40fcd6148c06de0532 /devel/p5-JSON-RPC-Dispatcher
parent39a0db131513f89094a8f7ba883b7a4b79f6ae9b (diff)
downloadports-694ede403d1791a6e9a4bb964917c55ccda73a37.tar.gz
ports-694ede403d1791a6e9a4bb964917c55ccda73a37.zip
JSON::RPC::Dispatcher can make any PSGI/Plack aware server a
JSON-RPC 2.0 server. This will allow you to expose your custom functionality as a web service in a relatiely tiny amount of code, as you can see above. This module follows the draft specficiation for JSON-RPC 2.0. More information can be found at: http://groups.google.com/group/json-rpc/web/json-rpc-2-0. WWW: http://search.cpan.org/dist/JSON-RPC-Dispatcher/
Notes
Notes: svn path=/head/; revision=252982
Diffstat (limited to 'devel/p5-JSON-RPC-Dispatcher')
-rw-r--r--devel/p5-JSON-RPC-Dispatcher/Makefile29
-rw-r--r--devel/p5-JSON-RPC-Dispatcher/distinfo3
-rw-r--r--devel/p5-JSON-RPC-Dispatcher/pkg-descr10
-rw-r--r--devel/p5-JSON-RPC-Dispatcher/pkg-plist10
4 files changed, 52 insertions, 0 deletions
diff --git a/devel/p5-JSON-RPC-Dispatcher/Makefile b/devel/p5-JSON-RPC-Dispatcher/Makefile
new file mode 100644
index 000000000000..d257b2147506
--- /dev/null
+++ b/devel/p5-JSON-RPC-Dispatcher/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-JSON-RPC-Dispatcher
+# Date created: 21 April, 2010
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JSON-RPC-Dispatcher
+PORTVERSION= 0.0402
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= A JSON-RPC 2.0 server
+
+BUILD_DEPENDS= p5-JSON>=2.16:${PORTSDIR}/converters/p5-JSON \
+ p5-Log-Any>=0.11:${PORTSDIR}/devel/p5-Log-Any \
+ p5-Moose>=0.93:${PORTSDIR}/devel/p5-Moose \
+ p5-Plack>=0.9913:${PORTSDIR}/www/p5-Plack
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= JSON::RPC::Dispatcher.3 \
+ JSON::RPC::Dispatcher::App.3 \
+ JSON::RPC::Dispatcher::Procedure.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-JSON-RPC-Dispatcher/distinfo b/devel/p5-JSON-RPC-Dispatcher/distinfo
new file mode 100644
index 000000000000..77b27dc70cc9
--- /dev/null
+++ b/devel/p5-JSON-RPC-Dispatcher/distinfo
@@ -0,0 +1,3 @@
+MD5 (JSON-RPC-Dispatcher-0.0402.tar.gz) = 29356410bc52f26d5e0a891b81a93680
+SHA256 (JSON-RPC-Dispatcher-0.0402.tar.gz) = fddbf45d19ebd86574be54d03befaf00b53ef1dfd7b6319c7fa4ce147b04e264
+SIZE (JSON-RPC-Dispatcher-0.0402.tar.gz) = 15028
diff --git a/devel/p5-JSON-RPC-Dispatcher/pkg-descr b/devel/p5-JSON-RPC-Dispatcher/pkg-descr
new file mode 100644
index 000000000000..4b7fa9e52903
--- /dev/null
+++ b/devel/p5-JSON-RPC-Dispatcher/pkg-descr
@@ -0,0 +1,10 @@
+JSON::RPC::Dispatcher can make any PSGI/Plack aware server a
+JSON-RPC 2.0 server. This will allow you to expose your custom
+functionality as a web service in a relatiely tiny amount of
+code, as you can see above.
+
+This module follows the draft specficiation for JSON-RPC 2.0.
+More information can be found at:
+http://groups.google.com/group/json-rpc/web/json-rpc-2-0.
+
+WWW: http://search.cpan.org/dist/JSON-RPC-Dispatcher/
diff --git a/devel/p5-JSON-RPC-Dispatcher/pkg-plist b/devel/p5-JSON-RPC-Dispatcher/pkg-plist
new file mode 100644
index 000000000000..73e8bea2fd02
--- /dev/null
+++ b/devel/p5-JSON-RPC-Dispatcher/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/RPC/Dispatcher/.packlist
+%%SITE_PERL%%/JSON/RPC/Dispatcher.pm
+%%SITE_PERL%%/JSON/RPC/Dispatcher/App.pm
+%%SITE_PERL%%/JSON/RPC/Dispatcher/Procedure.pm
+@dirrm %%SITE_PERL%%/JSON/RPC/Dispatcher
+@dirrmtry %%SITE_PERL%%/JSON/RPC
+@dirrmtry %%SITE_PERL%%/JSON
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/RPC/Dispatcher
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/RPC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON