aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Log-Handler
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-20 19:07:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-20 19:07:28 +0000
commit467b3f6da97ac8aef9f6abf28662229c022bced1 (patch)
treeb860bc279aeda7a180fa147726e96928a04faa46 /devel/p5-Log-Handler
parent6717322abb5c5e972b31b5a716d7796f31f1522e (diff)
downloadports-467b3f6da97ac8aef9f6abf28662229c022bced1.tar.gz
ports-467b3f6da97ac8aef9f6abf28662229c022bced1.zip
Log::Handler is an object-oriented handler for logging, tracing and
debugging. It is very easy to use and provides a simple interface for multiple output objects with lots of configuration parameters. WWW: http://search.cpan.org/dist/Log-Handler/ PR: ports/140371 Submitted by: Sahil Tandon <sahil at tandon.net>
Notes
Notes: svn path=/head/; revision=244546
Diffstat (limited to 'devel/p5-Log-Handler')
-rw-r--r--devel/p5-Log-Handler/Makefile39
-rw-r--r--devel/p5-Log-Handler/distinfo3
-rw-r--r--devel/p5-Log-Handler/pkg-descr5
-rw-r--r--devel/p5-Log-Handler/pkg-plist24
4 files changed, 71 insertions, 0 deletions
diff --git a/devel/p5-Log-Handler/Makefile b/devel/p5-Log-Handler/Makefile
new file mode 100644
index 000000000000..e3e95717e03b
--- /dev/null
+++ b/devel/p5-Log-Handler/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Log::Handler
+# Date created: 7 Nov 2009
+# Whom: Sahil Tandon <sahil@tandon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Handler
+PORTVERSION= 0.62
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sahil@tandon.net
+COMMENT= An object-oriented handler for logging, tracing and debugging in Perl
+
+BUILD_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Log::Handler.3 \
+ Log::Handler::Config.3 \
+ Log::Handler::Examples.3 \
+ Log::Handler::Levels.3 \
+ Log::Handler::Output.3 \
+ Log::Handler::Output::DBI.3 \
+ Log::Handler::Output::Email.3 \
+ Log::Handler::Output::File.3 \
+ Log::Handler::Output::Forward.3 \
+ Log::Handler::Output::Screen.3 \
+ Log::Handler::Output::Sendmail.3 \
+ Log::Handler::Output::Socket.3 \
+ Log::Handler::Pattern.3 \
+ Log::Handler::Plugin::Config::General.3 \
+ Log::Handler::Plugin::Config::Properties.3 \
+ Log::Handler::Plugin::YAML.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Log-Handler/distinfo b/devel/p5-Log-Handler/distinfo
new file mode 100644
index 000000000000..e8a909366de8
--- /dev/null
+++ b/devel/p5-Log-Handler/distinfo
@@ -0,0 +1,3 @@
+MD5 (Log-Handler-0.62.tar.gz) = ceb8e94193afa25bf971002579ae0a69
+SHA256 (Log-Handler-0.62.tar.gz) = 441e9224cf8c378bdad273880ed4289f6b50f4ecdad9d3850c7f8f198c83604f
+SIZE (Log-Handler-0.62.tar.gz) = 70719
diff --git a/devel/p5-Log-Handler/pkg-descr b/devel/p5-Log-Handler/pkg-descr
new file mode 100644
index 000000000000..641ce6e3e0a0
--- /dev/null
+++ b/devel/p5-Log-Handler/pkg-descr
@@ -0,0 +1,5 @@
+Log::Handler is an object-oriented handler for logging, tracing and
+debugging. It is very easy to use and provides a simple interface for
+multiple output objects with lots of configuration parameters.
+
+WWW: http://search.cpan.org/dist/Log-Handler/
diff --git a/devel/p5-Log-Handler/pkg-plist b/devel/p5-Log-Handler/pkg-plist
new file mode 100644
index 000000000000..f79d48147821
--- /dev/null
+++ b/devel/p5-Log-Handler/pkg-plist
@@ -0,0 +1,24 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Handler/.packlist
+%%SITE_PERL%%/Log/Handler.pm
+%%SITE_PERL%%/Log/Handler/Config.pm
+%%SITE_PERL%%/Log/Handler/Examples.pod
+%%SITE_PERL%%/Log/Handler/Levels.pm
+%%SITE_PERL%%/Log/Handler/Output.pm
+%%SITE_PERL%%/Log/Handler/Output/DBI.pm
+%%SITE_PERL%%/Log/Handler/Output/Email.pm
+%%SITE_PERL%%/Log/Handler/Output/File.pm
+%%SITE_PERL%%/Log/Handler/Output/Forward.pm
+%%SITE_PERL%%/Log/Handler/Output/Screen.pm
+%%SITE_PERL%%/Log/Handler/Output/Sendmail.pm
+%%SITE_PERL%%/Log/Handler/Output/Socket.pm
+%%SITE_PERL%%/Log/Handler/Pattern.pm
+%%SITE_PERL%%/Log/Handler/Plugin/Config/General.pm
+%%SITE_PERL%%/Log/Handler/Plugin/Config/Properties.pm
+%%SITE_PERL%%/Log/Handler/Plugin/YAML.pm
+@dirrm %%SITE_PERL%%/Log/Handler/Output
+@dirrm %%SITE_PERL%%/Log/Handler/Plugin/Config
+@dirrm %%SITE_PERL%%/Log/Handler/Plugin
+@dirrm %%SITE_PERL%%/Log/Handler
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Handler
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log
+@dirrmtry %%SITE_PERL%%/Log