aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Mknod
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-01-21 15:20:01 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-01-21 15:20:01 +0000
commitba1ab33456fe5db21fc6867a9bbd73cf0225f77e (patch)
treed588d01c8c945c4072c7892b5df264576ba8c432 /devel/p5-Mknod
parent9f91b2f382436f9acda9315226cf4eda35c7b924 (diff)
downloadports-ba1ab33456fe5db21fc6867a9bbd73cf0225f77e.tar.gz
ports-ba1ab33456fe5db21fc6867a9bbd73cf0225f77e.zip
Mknod is an interface to the mknod(2) system call.
PR: ports/73513 Submitted by: Sean Farley <sean-freebsd(at)farley.org>
Notes
Notes: svn path=/head/; revision=127016
Diffstat (limited to 'devel/p5-Mknod')
-rw-r--r--devel/p5-Mknod/Makefile30
-rw-r--r--devel/p5-Mknod/distinfo2
-rw-r--r--devel/p5-Mknod/pkg-descr7
-rw-r--r--devel/p5-Mknod/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-Mknod/Makefile b/devel/p5-Mknod/Makefile
new file mode 100644
index 000000000000..4415bae84f23
--- /dev/null
+++ b/devel/p5-Mknod/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Mknod
+# Date created: 3 November 2004
+# Whom: Sean Farley <sean-freebsd@farley.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mknod
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/R/RL/RLZWART
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sean-freebsd@farley.org
+COMMENT= Perl module interface to the mknod(2) system call
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${SITE_PERL}
+MAN3= Mknod.3
+
+.include <bsd.port.pre.mk>
+
+# This port requires PERL 5.6.x or later.
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Mknod/distinfo b/devel/p5-Mknod/distinfo
new file mode 100644
index 000000000000..e22c19c98da1
--- /dev/null
+++ b/devel/p5-Mknod/distinfo
@@ -0,0 +1,2 @@
+MD5 (Mknod-0.02.tar.gz) = f81801b1cc38c5e3ec9a755085e50dbb
+SIZE (Mknod-0.02.tar.gz) = 7591
diff --git a/devel/p5-Mknod/pkg-descr b/devel/p5-Mknod/pkg-descr
new file mode 100644
index 000000000000..efc6bf4445fd
--- /dev/null
+++ b/devel/p5-Mknod/pkg-descr
@@ -0,0 +1,7 @@
+Mknod is an interface to the mknod(2) system call.
+
+
+Copyright (C) 2003 Raoul Zwart
+
+This library is free software; you can redistribute it and/or modify it under
+the same terms as Perl itself.
diff --git a/devel/p5-Mknod/pkg-plist b/devel/p5-Mknod/pkg-plist
new file mode 100644
index 000000000000..67416447065f
--- /dev/null
+++ b/devel/p5-Mknod/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Mknod.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mknod/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mknod/Mknod.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mknod/Mknod.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mknod