aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Build
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-04-02 07:31:45 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-04-02 07:31:45 +0000
commit003620c0c4da2e3e6756fbcc62653da110ee1edf (patch)
treeb1f5e91199300181a172d2fc4dfd6ad97121bf79 /devel/p5-Module-Build
parent98dd96ee205fb968db4585e6da5e5fbdd9c840fb (diff)
downloadports-003620c0c4da2e3e6756fbcc62653da110ee1edf.tar.gz
ports-003620c0c4da2e3e6756fbcc62653da110ee1edf.zip
Use PERL_MODBUILD now that bsd.port.mk has been changed to allow it without
infinite recursion. Submitted by: mat PR: 62422
Notes
Notes: svn path=/head/; revision=105949
Diffstat (limited to 'devel/p5-Module-Build')
-rw-r--r--devel/p5-Module-Build/Makefile20
1 files changed, 1 insertions, 19 deletions
diff --git a/devel/p5-Module-Build/Makefile b/devel/p5-Module-Build/Makefile
index 0215d04b0ca4..d36d3489fed9 100644
--- a/devel/p5-Module-Build/Makefile
+++ b/devel/p5-Module-Build/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar
${SITE_PERL}/Pod/Man.pm:${PORTSDIR}/textproc/p5-podlators
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
MAN3= Module::Build.3 \
Module::Build::Base.3 \
@@ -42,24 +42,6 @@ MAN3= Module::Build.3 \
Module::Build::Platform::darwin.3 \
Module::Build::Platform::os2.3
-PERL_CONFIGURE= yes
-CONFIGURE_SCRIPT?= Build.PL
-ALL_TARGET?=
-PL_BUILD?= Build
-CONFIGURE_ARGS+= \
- install_path=lib="${PREFIX}/${SITE_PERL_REL}" \
- install_path=arch="${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}" \
- install_path=script="${PREFIX}/bin" \
- install_path=bin="${PREFIX}/bin" \
- install_path=libdoc="${MAN3PREFIX}/man/man3" \
- install_path=bindoc="${MAN1PREFIX}/man/man1"
-
-do-build:
- @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} ${PL_BUILD} ${MAKE_ARGS} ${ALL_TARGET})
-
-do-install:
- @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} ${PL_BUILD} ${MAKE_ARGS} ${INSTALL_TARGET})
-
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} > 500600