aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Inspector
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:13:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:13:00 +0000
commit8dcdff4db8b4d8e5b4b3c2bc54f33af4a6d07166 (patch)
tree248c2a8029f01a96a254b5bb4db91006a9c3ecb0 /devel/p5-Module-Inspector
parent71bdcbfd92f8af8bd9df7895edd46bd57fb6b641 (diff)
downloadports-8dcdff4db8b4d8e5b4b3c2bc54f33af4a6d07166.tar.gz
ports-8dcdff4db8b4d8e5b4b3c2bc54f33af4a6d07166.zip
Module::Inspector provides a wrapper around various modules used to read and
examine the different parts of a Perl module distribution tarball, and can inspect a module unrolled on disk, in a repository checkout, or just look directly inside a tarball. It also rovides a companion to the Class::Inspector API for accessing information on class after installation. WWW: http://search.cpan.org/dist/Module-Inspector/ PR: ports/132406 Submitted by: Cezary Morga <cm at therek.net>
Notes
Notes: svn path=/head/; revision=230135
Diffstat (limited to 'devel/p5-Module-Inspector')
-rw-r--r--devel/p5-Module-Inspector/Makefile32
-rw-r--r--devel/p5-Module-Inspector/distinfo3
-rw-r--r--devel/p5-Module-Inspector/pkg-descr7
-rw-r--r--devel/p5-Module-Inspector/pkg-plist3
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/p5-Module-Inspector/Makefile b/devel/p5-Module-Inspector/Makefile
new file mode 100644
index 000000000000..c020dba314b9
--- /dev/null
+++ b/devel/p5-Module-Inspector/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Module-Inspector
+# Date created: March 8th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Inspector
+PORTVERSION= 1.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= An integrated API for inspecting Perl distributions
+
+BUILD_DEPENDS= ${SITE_PERL}/File/Find/Rule/VCS.pm:${PORTSDIR}/devel/p5-File-Find-Rule-VCS \
+ ${SITE_PERL}/File/Find/Rule/Perl.pm:${PORTSDIR}/devel/p5-File-Find-Rule-Perl \
+ ${SITE_PERL}/Module/Extract.pm:${PORTSDIR}/devel/p5-Module-Extract \
+ ${SITE_PERL}/Module/Manifest.pm:${PORTSDIR}/devel/p5-Module-Manifest \
+ ${SITE_PERL}/Module/Math/Depends.pm:${PORTSDIR}/devel/p5-Module-Math-Depends \
+ ${SITE_PERL}/PPI.pm:${PORTSDIR}/textproc/p5-PPI \
+ ${SITE_PERL}/YAML/Tiny.pm:${PORTSDIR}/textproc/p5-YAML-Tiny \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
+ ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Module::Inspector.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Module-Inspector/distinfo b/devel/p5-Module-Inspector/distinfo
new file mode 100644
index 000000000000..4d3069d9c1e2
--- /dev/null
+++ b/devel/p5-Module-Inspector/distinfo
@@ -0,0 +1,3 @@
+MD5 (Module-Inspector-1.05.tar.gz) = 3c433283d048cc7d4dd005e7db033700
+SHA256 (Module-Inspector-1.05.tar.gz) = cca026875c338b46e6c9938ca8f0d88a88cebf39c3a18c9539e565a03a49ad65
+SIZE (Module-Inspector-1.05.tar.gz) = 54202
diff --git a/devel/p5-Module-Inspector/pkg-descr b/devel/p5-Module-Inspector/pkg-descr
new file mode 100644
index 000000000000..d698d780c958
--- /dev/null
+++ b/devel/p5-Module-Inspector/pkg-descr
@@ -0,0 +1,7 @@
+Module::Inspector provides a wrapper around various modules used to read and
+examine the different parts of a Perl module distribution tarball, and can
+inspect a module unrolled on disk, in a repository checkout, or just look
+directly inside a tarball. It also rovides a companion to the Class::Inspector
+API for accessing information on class after installation.
+
+WWW: http://search.cpan.org/dist/Module-Inspector/
diff --git a/devel/p5-Module-Inspector/pkg-plist b/devel/p5-Module-Inspector/pkg-plist
new file mode 100644
index 000000000000..84526e6a2570
--- /dev/null
+++ b/devel/p5-Module-Inspector/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Module/Inspector.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Inspector/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Module/Inspector