aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Load-Conditional/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-12-15 10:10:11 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-12-15 10:10:11 +0000
commit4e4fe67b87302b2acb26df616dd280ffa07a23bd (patch)
tree94a5b5cacd91bd08514f9c42dacb68a12f78ff88 /devel/p5-Module-Load-Conditional/Makefile
parent9412503150b65efac644e422f8b850ad0c17f071 (diff)
downloadports-4e4fe67b87302b2acb26df616dd280ffa07a23bd.tar.gz
ports-4e4fe67b87302b2acb26df616dd280ffa07a23bd.zip
Add p5-Module-Load-Conditional, a Perl module for looking up other Perl
modules information/loading at runtime.
Notes
Notes: svn path=/head/; revision=124090
Diffstat (limited to 'devel/p5-Module-Load-Conditional/Makefile')
-rw-r--r--devel/p5-Module-Load-Conditional/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/p5-Module-Load-Conditional/Makefile b/devel/p5-Module-Load-Conditional/Makefile
new file mode 100644
index 000000000000..de5cdacfa0d9
--- /dev/null
+++ b/devel/p5-Module-Load-Conditional/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: devel/p5-Module-Load-Conditional
+# Date created: 15 December 2004
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Load-Conditional
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Module
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Looking up Perl modules information/loading at runtime
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Module/Load.pm:${PORTSDIR}/devel/p5-Module-Load \
+ ${SITE_PERL}/Locale/Maketext/Simple.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
+ ${SITE_PERL}/Params/Check.pm:${PORTSDIR}/devel/p5-Params-Check
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Module::Load::Conditional.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500600
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
+
+.include <bsd.port.post.mk>