aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Load-Conditional
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-01-29 09:09:16 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-01-29 09:09:16 +0000
commit58dd600615034070f44ccc104d62bdea5f350a16 (patch)
tree2bdf66f48043e2a28d42c0e98c138602db36dee6 /devel/p5-Module-Load-Conditional
parentbc0fd99eb960a82bd4c3d1b66a545990a4baa904 (diff)
downloadports-58dd600615034070f44ccc104d62bdea5f350a16.tar.gz
ports-58dd600615034070f44ccc104d62bdea5f350a16.zip
Add missing dependency. Require perl from ports. Bump portrevision.
Notes
Notes: svn path=/head/; revision=183605
Diffstat (limited to 'devel/p5-Module-Load-Conditional')
-rw-r--r--devel/p5-Module-Load-Conditional/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/devel/p5-Module-Load-Conditional/Makefile b/devel/p5-Module-Load-Conditional/Makefile
index 06932da231ab..07d32bfd9394 100644
--- a/devel/p5-Module-Load-Conditional/Makefile
+++ b/devel/p5-Module-Load-Conditional/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Module-Load-Conditional
PORTVERSION= 0.16
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Module
@@ -18,7 +19,8 @@ COMMENT= Looking up Perl modules information/loading at runtime
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
${SITE_PERL}/Locale/Maketext/Simple.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
${SITE_PERL}/Module/Load.pm:${PORTSDIR}/devel/p5-Module-Load \
- ${SITE_PERL}/Params/Check.pm:${PORTSDIR}/devel/p5-Params-Check
+ ${SITE_PERL}/Params/Check.pm:${PORTSDIR}/devel/p5-Params-Check \
+ p5-version>=0.69:${PORTSDIR}/devel/p5-version
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -34,4 +36,10 @@ post-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>