aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Perl6-Builtins/Makefile
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2007-07-28 13:09:17 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2007-07-28 13:09:17 +0000
commite1ef09b7cfe3bae67373f419a3a33c0dcc190376 (patch)
tree473909b839140669eb227cdd9b08d7137ba05f8a /devel/p5-Perl6-Builtins/Makefile
parent605b51623904901c5be12539309f2345d1751741 (diff)
downloadports-e1ef09b7cfe3bae67373f419a3a33c0dcc190376.tar.gz
ports-e1ef09b7cfe3bae67373f419a3a33c0dcc190376.zip
Add p5-Perl6-Builtins,
Several of the builtins in Perl 6 have different (i.e. more useful, less confusing) behaviours than their Perl 5 counterparts. This module provides Perl 5 versions of those builtins. Approved by: rafan (memtor, implicit)
Notes
Notes: svn path=/head/; revision=196464
Diffstat (limited to 'devel/p5-Perl6-Builtins/Makefile')
-rw-r--r--devel/p5-Perl6-Builtins/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/p5-Perl6-Builtins/Makefile b/devel/p5-Perl6-Builtins/Makefile
new file mode 100644
index 000000000000..222dd931d05a
--- /dev/null
+++ b/devel/p5-Perl6-Builtins/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-Perl6-Builtins
+# Date created: 2007/07/28
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Perl6-Builtins
+PORTVERSION= 0.0.3
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Perl6
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Provide Perl 5 versions of the new Perl 6 builtins
+
+BUILD_DEPENDS= p5-Contextual-Return>=0:${PORTSDIR}/devel/p5-Contextual-Return \
+ p5-version>=0:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Perl6::Builtins.3
+
+.include <bsd.port.mk>