aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Perl6-Slurp/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-05 16:40:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-05 16:40:10 +0000
commite328cf3360bc303c5a41c4bbe8c4137a02dacb9b (patch)
tree1bec1cca7626fce1901e376708d653fe624f246b /devel/p5-Perl6-Slurp/Makefile
parentba8e0b6569b9831b5167f6a2e8f4492b2dc217fd (diff)
downloadports-e328cf3360bc303c5a41c4bbe8c4137a02dacb9b.tar.gz
ports-e328cf3360bc303c5a41c4bbe8c4137a02dacb9b.zip
- Add p5-Perl6-Slurp 0.03
Perl6::Slurp implements the Perl 6 'slurp' built-in. slurp takes a filename, a filehandle, a typeglob reference, an IO::File object, or a scalar reference, and converts it to an input stream if necessary, and reads in the entire stream. If slurp fails to set up or read the stream, it throws an exception. WWW: http://search.cpan.org/dist/Perl6-Slurp/
Notes
Notes: svn path=/head/; revision=285093
Diffstat (limited to 'devel/p5-Perl6-Slurp/Makefile')
-rw-r--r--devel/p5-Perl6-Slurp/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/p5-Perl6-Slurp/Makefile b/devel/p5-Perl6-Slurp/Makefile
new file mode 100644
index 000000000000..78e6e00c2d42
--- /dev/null
+++ b/devel/p5-Perl6-Slurp/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Perl6-Slurp
+# Date created: 2011-11-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Perl6-Slurp
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Implements the Perl6 'slurp' built-in
+
+BUILD_DEPENDS= p5-Perl6-Export>=0.07:${PORTSDIR}/devel/p5-Perl6-Export
+RUN_DEPENDS= p5-Perl6-Export>=0.07:${PORTSDIR}/devel/p5-Perl6-Export
+
+PERL_CONFIGURE= yes
+
+MAN3= Perl6::Slurp.3
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>