aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Sort-Tree
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-10-17 07:26:01 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-10-17 07:26:01 +0000
commite37958e8264692c44d7b4efbe93f4c43aebeac9e (patch)
tree37b2d250c902a03d6744a1d421d30b282ec86eed /devel/p5-Sort-Tree
parent688e50dcd07ddce9f3c6ec67ceffc23ed2952fe8 (diff)
downloadports-e37958e8264692c44d7b4efbe93f4c43aebeac9e.tar.gz
ports-e37958e8264692c44d7b4efbe93f4c43aebeac9e.zip
Add p5-Sort-Tree 1.08,
a perl module for sorting a objects into a tree structure. PR: 58079 Submitted by: clsung@dragon2.net
Notes
Notes: svn path=/head/; revision=91483
Diffstat (limited to 'devel/p5-Sort-Tree')
-rw-r--r--devel/p5-Sort-Tree/Makefile22
-rw-r--r--devel/p5-Sort-Tree/distinfo1
-rw-r--r--devel/p5-Sort-Tree/pkg-descr19
-rw-r--r--devel/p5-Sort-Tree/pkg-plist5
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Sort-Tree/Makefile b/devel/p5-Sort-Tree/Makefile
new file mode 100644
index 000000000000..8e067cfd4c7a
--- /dev/null
+++ b/devel/p5-Sort-Tree/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Sort-Tree
+# Date created: Oct 16th 2003
+# Whom: clsung@dragon2.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sort-Tree
+PORTVERSION= 1.08
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sort
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= A perl module for sorting a objects into a tree structure
+
+PERL_CONFIGURE= YES
+
+MAN3= Sort::Tree.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Sort-Tree/distinfo b/devel/p5-Sort-Tree/distinfo
new file mode 100644
index 000000000000..871ed8f2e4d3
--- /dev/null
+++ b/devel/p5-Sort-Tree/distinfo
@@ -0,0 +1 @@
+MD5 (Sort-Tree-1.08.tar.gz) = 7140a2631ad9713913ea59ff25e88ddd
diff --git a/devel/p5-Sort-Tree/pkg-descr b/devel/p5-Sort-Tree/pkg-descr
new file mode 100644
index 000000000000..31ad38c97e2b
--- /dev/null
+++ b/devel/p5-Sort-Tree/pkg-descr
@@ -0,0 +1,19 @@
+Sort::Tree implements a mechanism for sorting a list of objects into a
+tree structure and flattening it back into a list. Among other things,
+this is useful for displaying database queries in hierarchical views,
+such as nested categories, parent-child relationships, threaded
+discussions, and so forth.
+
+Trees have a lot to do with Graph theory, so if this module doesn't suit
+your fancy, have a look at the Graph:: Perl modules for an academically
+oriented implementation that employs vertex, edge, and node operations.
+
+For more information on how to use the perl module, see the
+pod documentation via the command
+ perldoc Sort::Tree
+or, after installation, view the man pages with
+ man Sort::Tree
+
+WWW: http://search.cpan.org/search?dist=Sort-Tree
+
+Author: Bryce Harrington <brycehar@bryceharrington.com>
diff --git a/devel/p5-Sort-Tree/pkg-plist b/devel/p5-Sort-Tree/pkg-plist
new file mode 100644
index 000000000000..35aaa7d3bf8c
--- /dev/null
+++ b/devel/p5-Sort-Tree/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Sort/Tree.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort/Tree/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort/Tree
+@unexec rmdir %D/%%SITE_PERL%%/Sort 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort 2>/dev/null || true