aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Spoon/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-07-17 01:59:30 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-07-17 01:59:30 +0000
commit919b1245887133716445282956eec4f35200a681 (patch)
tree988132dea77dca2806ea984e0129fc68043e787e /devel/p5-Spoon/Makefile
parent4982d9a25d2f0446a15a6ebbb673aa80eea8023e (diff)
downloadports-919b1245887133716445282956eec4f35200a681.tar.gz
ports-919b1245887133716445282956eec4f35200a681.zip
Add p5-Spoon 0.16, a Spiffy Application Building Framework.
PR: ports/69140 Submitted by: Cheng-Lung Sung <clsung@dragon2.net>
Notes
Notes: svn path=/head/; revision=113789
Diffstat (limited to 'devel/p5-Spoon/Makefile')
-rw-r--r--devel/p5-Spoon/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Spoon/Makefile b/devel/p5-Spoon/Makefile
new file mode 100644
index 000000000000..08d4a5959533
--- /dev/null
+++ b/devel/p5-Spoon/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: p5-Spoon
+# Date created: Fri Jul 16 14:17:55 CST 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Spoon
+PORTVERSION= 0.16
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/I/IN/INGY/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A Spiffy Application Building Framework
+
+BUILD_DEPENDS= ${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy \
+ ${SITE_PERL}/IO/All.pm:${PORTSDIR}/devel/p5-IO-All \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Spoon.3 \
+ Spoon::Base.3 \
+ Spoon::CGI.3 \
+ Spoon::Config.3 \
+ Spoon::ContentObject.3 \
+ Spoon::Cookie.3 \
+ Spoon::DataObject.3 \
+ Spoon::Formatter.3 \
+ Spoon::Hub.3 \
+ Spoon::Installer.3 \
+ Spoon::MetadataObject.3 \
+ Spoon::Template.3 \
+ Spoon::Template::TT2.3 \
+ Spoon::Registry.3 \
+ Spoon::Plugin.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>