aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-String-Random
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-03 23:51:52 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-03 23:51:52 +0000
commit7b31e1730dbf7f0509f08decc3e1291f05c44b25 (patch)
treec571561c54271acea3cb34f4c8fa6f261201fad2 /devel/p5-String-Random
parentb4edb5af14bcd9769dc8cadaeda4c7d75c1d590f (diff)
downloadports-7b31e1730dbf7f0509f08decc3e1291f05c44b25.tar.gz
ports-7b31e1730dbf7f0509f08decc3e1291f05c44b25.zip
Add p5-String-Random 0.198, a perl interface to generate "random" strings.
Notes
Notes: svn path=/head/; revision=36738
Diffstat (limited to 'devel/p5-String-Random')
-rw-r--r--devel/p5-String-Random/Makefile23
-rw-r--r--devel/p5-String-Random/distinfo1
-rw-r--r--devel/p5-String-Random/pkg-comment1
-rw-r--r--devel/p5-String-Random/pkg-descr7
-rw-r--r--devel/p5-String-Random/pkg-plist3
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/p5-String-Random/Makefile b/devel/p5-String-Random/Makefile
new file mode 100644
index 000000000000..cadd90aae1cb
--- /dev/null
+++ b/devel/p5-String-Random/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: String-Random
+# Date created: Mon Jan 1 11:19:27 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Random
+PORTVERSION= 0.198
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= String
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= String::Random.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-String-Random/distinfo b/devel/p5-String-Random/distinfo
new file mode 100644
index 000000000000..a36bb4dfd9b0
--- /dev/null
+++ b/devel/p5-String-Random/distinfo
@@ -0,0 +1 @@
+MD5 (String-Random-0.198.tar.gz) = 5556b44648a80b0bcb0114eecc5d4082
diff --git a/devel/p5-String-Random/pkg-comment b/devel/p5-String-Random/pkg-comment
new file mode 100644
index 000000000000..4361762fd0d0
--- /dev/null
+++ b/devel/p5-String-Random/pkg-comment
@@ -0,0 +1 @@
+Perl interface to generate "random" strings
diff --git a/devel/p5-String-Random/pkg-descr b/devel/p5-String-Random/pkg-descr
new file mode 100644
index 000000000000..e1d8a6f8eb17
--- /dev/null
+++ b/devel/p5-String-Random/pkg-descr
@@ -0,0 +1,7 @@
+String::Random is used to generate random strings. It was written to
+make generating random passwords and such a little easier. See the
+documentation in pod format in the module for more information.
+
+Author: Steven Pritchard <steve@silug.org>
+
+--will
diff --git a/devel/p5-String-Random/pkg-plist b/devel/p5-String-Random/pkg-plist
new file mode 100644
index 000000000000..1907d8e5412e
--- /dev/null
+++ b/devel/p5-String-Random/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/String/Random.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/Random/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/Random