aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Sub-Name
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-11-27 14:54:40 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-11-27 14:54:40 +0000
commit48789882f9ce9ebf1c79223104766f3c6b8392ef (patch)
tree91bfe0ca71b2c1a595c965d19b9c75765a074e4a /devel/p5-Sub-Name
parent7c7394f05fcd9764caf7f94ad619cc9cb3bf2875 (diff)
downloadports-48789882f9ce9ebf1c79223104766f3c6b8392ef.tar.gz
ports-48789882f9ce9ebf1c79223104766f3c6b8392ef.zip
Add devel/p5-Sub-Name, a Perl module to dynamically assign names to Perl
subroutines.
Notes
Notes: svn path=/head/; revision=149673
Diffstat (limited to 'devel/p5-Sub-Name')
-rw-r--r--devel/p5-Sub-Name/Makefile28
-rw-r--r--devel/p5-Sub-Name/distinfo3
-rw-r--r--devel/p5-Sub-Name/pkg-descr9
-rw-r--r--devel/p5-Sub-Name/pkg-plist7
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Sub-Name/Makefile b/devel/p5-Sub-Name/Makefile
new file mode 100644
index 000000000000..e6d848a949e1
--- /dev/null
+++ b/devel/p5-Sub-Name/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-Sub-Name
+# Date created: 27 November 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Name
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sub
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Sub::Name - (re)name a sub
+
+PERL_CONFIGURE= yes
+
+MAN3= Sub::Name.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Sub-Name/distinfo b/devel/p5-Sub-Name/distinfo
new file mode 100644
index 000000000000..6b45f0aed005
--- /dev/null
+++ b/devel/p5-Sub-Name/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sub-Name-0.02.tar.gz) = a47e1f1fe88a0c85b7ecc0d150039616
+SHA256 (Sub-Name-0.02.tar.gz) = 41b48f55165207c7dc33a4354349784c29f4c3a7338ee32ddf73641da11b507a
+SIZE (Sub-Name-0.02.tar.gz) = 2686
diff --git a/devel/p5-Sub-Name/pkg-descr b/devel/p5-Sub-Name/pkg-descr
new file mode 100644
index 000000000000..80f30b6d0b73
--- /dev/null
+++ b/devel/p5-Sub-Name/pkg-descr
@@ -0,0 +1,9 @@
+The subname() function exported by this module allows one to assign new
+names to Perl subroutine. This is different from glob-assignment, since
+the name is only used for informational purposes (caller, Carp, etc.).
+
+Note that for anonymous closures (subs that reference lexicals declared
+outside the sub itself) one can name each instance of the closure
+differently, which can be very useful for debugging.
+
+WWW: http://search.cpan.org/dist/Sub-Name/
diff --git a/devel/p5-Sub-Name/pkg-plist b/devel/p5-Sub-Name/pkg-plist
new file mode 100644
index 000000000000..b60cc85f587d
--- /dev/null
+++ b/devel/p5-Sub-Name/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Sub/Name.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Name/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Name/Name.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Name/Name.so
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Name 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Sub 2>/dev/null || true