aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Differences
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-04 10:52:56 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-04 10:52:56 +0000
commit62f59acea2f0a2e4a80437060785420eb1b85ef3 (patch)
treee11b04eb3169bd23775b6cd87799ef799756c8cc /devel/p5-Test-Differences
parentf6483bb9112289ab751d03e0e5bdd98e04edf1d3 (diff)
downloadports-62f59acea2f0a2e4a80437060785420eb1b85ef3.tar.gz
ports-62f59acea2f0a2e4a80437060785420eb1b85ef3.zip
New port: Test::Differences - Test strings and data structures for differences
When the code you're testing returns multiple lines, records or data structures and they're just plain wrong, an equivalent to the Unix diff utility may be just what's needed. PR: ports/47588 Submitted by: Erwin Lansing <erwin@lansing.dk>
Notes
Notes: svn path=/head/; revision=74636
Diffstat (limited to 'devel/p5-Test-Differences')
-rw-r--r--devel/p5-Test-Differences/Makefile26
-rw-r--r--devel/p5-Test-Differences/distinfo1
-rw-r--r--devel/p5-Test-Differences/pkg-comment1
-rw-r--r--devel/p5-Test-Differences/pkg-descr5
-rw-r--r--devel/p5-Test-Differences/pkg-plist4
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/p5-Test-Differences/Makefile b/devel/p5-Test-Differences/Makefile
new file mode 100644
index 000000000000..7ff49777f532
--- /dev/null
+++ b/devel/p5-Test-Differences/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Test-Differences
+# Date created: January 28th 2003
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Differences
+PORTVERSION= 0.46
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Test::Differences.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Differences/distinfo b/devel/p5-Test-Differences/distinfo
new file mode 100644
index 000000000000..5342044ef89d
--- /dev/null
+++ b/devel/p5-Test-Differences/distinfo
@@ -0,0 +1 @@
+MD5 (Test-Differences-0.46.tar.gz) = 802b0c0fd801657588c2515d738c5665
diff --git a/devel/p5-Test-Differences/pkg-comment b/devel/p5-Test-Differences/pkg-comment
new file mode 100644
index 000000000000..fedee812aed9
--- /dev/null
+++ b/devel/p5-Test-Differences/pkg-comment
@@ -0,0 +1 @@
+Test::Differences - Test strings and data structures for differences
diff --git a/devel/p5-Test-Differences/pkg-descr b/devel/p5-Test-Differences/pkg-descr
new file mode 100644
index 000000000000..5331e1c78a13
--- /dev/null
+++ b/devel/p5-Test-Differences/pkg-descr
@@ -0,0 +1,5 @@
+When the code you're testing returns multiple lines, records
+or data structures and they're just plain wrong, an equivalent
+to the Unix diff utility may be just what's needed.
+
+WWW: http://search.cpan.org/dist/Test-Differences/
diff --git a/devel/p5-Test-Differences/pkg-plist b/devel/p5-Test-Differences/pkg-plist
new file mode 100644
index 000000000000..8aa384cfe880
--- /dev/null
+++ b/devel/p5-Test-Differences/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Test/Differences/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Test/Differences.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Test/Differences
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Test 2>/dev/null || true