aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Expect
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-23 16:14:58 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-23 16:14:58 +0000
commit37a8e9f8717df929a86b1b6a73d74f25df76ec85 (patch)
tree019cf14c0c5d2d68cfb21c5be781dcde7225ca8e /devel/p5-Test-Expect
parentee9c14b114a5735f96ea3d27b125339707df9afc (diff)
downloadports-37a8e9f8717df929a86b1b6a73d74f25df76ec85.tar.gz
ports-37a8e9f8717df929a86b1b6a73d74f25df76ec85.zip
Adding port devel/p5-Test-Expect, Automated driving and testing of terminal-based programs.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163184
Diffstat (limited to 'devel/p5-Test-Expect')
-rw-r--r--devel/p5-Test-Expect/Makefile32
-rw-r--r--devel/p5-Test-Expect/distinfo3
-rw-r--r--devel/p5-Test-Expect/pkg-descr10
-rw-r--r--devel/p5-Test-Expect/pkg-plist5
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-Test-Expect/Makefile b/devel/p5-Test-Expect/Makefile
new file mode 100644
index 000000000000..a94eb00e146b
--- /dev/null
+++ b/devel/p5-Test-Expect/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Test-Expect
+# Date created: 23 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Expect
+PORTVERSION= 0.30
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Automated driving and testing of terminal-based programs
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor/Chained/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor-Chained \
+ ${SITE_PERL}/Expect/Simple.pm:${PORTSDIR}/devel/p5-Expect-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Test::Expect.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8.0. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Expect/distinfo b/devel/p5-Test-Expect/distinfo
new file mode 100644
index 000000000000..122bac1ed6f3
--- /dev/null
+++ b/devel/p5-Test-Expect/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Expect-0.30.tar.gz) = b22cb4575d910bb2d36e506a958da300
+SHA256 (Test-Expect-0.30.tar.gz) = 2fd80e0748a6edc140655bdd688b443fec7978d42c6b73571e6aa85f1d35cf6c
+SIZE (Test-Expect-0.30.tar.gz) = 3099
diff --git a/devel/p5-Test-Expect/pkg-descr b/devel/p5-Test-Expect/pkg-descr
new file mode 100644
index 000000000000..2263c5642851
--- /dev/null
+++ b/devel/p5-Test-Expect/pkg-descr
@@ -0,0 +1,10 @@
+Test::Expect is a module for automated driving and testing of
+terminal-based programs. It is handy for testing interactive programs
+which have a prompt, and is based on the same concepts as the Tcl Expect
+tool. As in Expect::Simple, the Expect object is made available for
+tweaking.
+
+Test::Expect is intended for use in a test script.
+
+WWW: http://search.cpan.org/dist/Test-Expect
+Author: Leon Brocard <acme@astray.com>
diff --git a/devel/p5-Test-Expect/pkg-plist b/devel/p5-Test-Expect/pkg-plist
new file mode 100644
index 000000000000..ac298fe123ad
--- /dev/null
+++ b/devel/p5-Test-Expect/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/Expect.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Expect/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Expect
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test