aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Inline
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-09-12 11:03:09 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-09-12 11:03:09 +0000
commit73f5cd61d6cb9f792fd70ff8616763df1e8d26cd (patch)
tree14a6888d008cb48ee60119703dcbb5337cac59d9 /devel/p5-Test-Inline
parentbcefd25e0c7f133d1374ba5086a0dfac0f43e8d3 (diff)
downloadports-73f5cd61d6cb9f792fd70ff8616763df1e8d26cd.tar.gz
ports-73f5cd61d6cb9f792fd70ff8616763df1e8d26cd.zip
Add p5-Test-Inline 0.15, Test::Inline - inlining your tests next to the
code being tested. PR: 42687 Submitted by: Erwin Lansing <erwin@lansing.dk>
Notes
Notes: svn path=/head/; revision=66193
Diffstat (limited to 'devel/p5-Test-Inline')
-rw-r--r--devel/p5-Test-Inline/Makefile28
-rw-r--r--devel/p5-Test-Inline/distinfo1
-rw-r--r--devel/p5-Test-Inline/pkg-comment1
-rw-r--r--devel/p5-Test-Inline/pkg-descr11
-rw-r--r--devel/p5-Test-Inline/pkg-plist12
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/p5-Test-Inline/Makefile b/devel/p5-Test-Inline/Makefile
new file mode 100644
index 000000000000..af2816c9d678
--- /dev/null
+++ b/devel/p5-Test-Inline/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Test-Inline
+# Date created: Mon Sep 12
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Inline
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= pod2test.1
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Pod::Tests.3 Pod::Tests::Tutorial.3 Test::Inline.3 Test::Inline::Tutorial.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Inline/distinfo b/devel/p5-Test-Inline/distinfo
new file mode 100644
index 000000000000..42fd2647bc57
--- /dev/null
+++ b/devel/p5-Test-Inline/distinfo
@@ -0,0 +1 @@
+MD5 (Test-Inline-0.15.tar.gz) = 8b1128b4102578c093a01ad0b86f6616
diff --git a/devel/p5-Test-Inline/pkg-comment b/devel/p5-Test-Inline/pkg-comment
new file mode 100644
index 000000000000..c79257d59feb
--- /dev/null
+++ b/devel/p5-Test-Inline/pkg-comment
@@ -0,0 +1 @@
+Test::Inline - Inlining your tests next to the code being tested
diff --git a/devel/p5-Test-Inline/pkg-descr b/devel/p5-Test-Inline/pkg-descr
new file mode 100644
index 000000000000..8eda9ccbc4b6
--- /dev/null
+++ b/devel/p5-Test-Inline/pkg-descr
@@ -0,0 +1,11 @@
+Embedding tests allows tests to be placed near the code its testing.
+This is a nice supplement to the traditional .t files.
+It's like XUnit, Perl-style.
+
+Test::Tutorial is just documentation. To actually get anything done you
+use pod2test. Read the Test::Inline::Tutoral, really.
+
+Author: Michael G Schwern <schwern@pobox.com>
+WWW: http://search.cpan.org/search?dist=Test-Inline
+
+--Erwin Lansing <erwin@lansing.dk>
diff --git a/devel/p5-Test-Inline/pkg-plist b/devel/p5-Test-Inline/pkg-plist
new file mode 100644
index 000000000000..25e0eb2450a9
--- /dev/null
+++ b/devel/p5-Test-Inline/pkg-plist
@@ -0,0 +1,12 @@
+bin/pod2test
+lib/perl5/site_perl/%%PERL_VER%%/Test/Inline/Tutorial.pod
+lib/perl5/site_perl/%%PERL_VER%%/Test/Inline.pm
+lib/perl5/site_perl/%%PERL_VER%%/Pod/Tests.pm
+lib/perl5/site_perl/%%PERL_VER%%/Pod/Tests/Tutorial.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Test/Inline/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Test/Inline
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Test/Inline
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Test 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Pod/Tests
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Pod 2>/dev/null || true