aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-WWW-Mechanize-Catalyst
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-11-17 19:38:39 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-11-17 19:38:39 +0000
commit65b285333642909ba542fac693c78531b3250456 (patch)
treeded471bddbf413aab458067b086fd8a8b9e3037c /devel/p5-Test-WWW-Mechanize-Catalyst
parent59b130b4abaf2919abc8e6a3613301d53c336c7a (diff)
downloadports-65b285333642909ba542fac693c78531b3250456.tar.gz
ports-65b285333642909ba542fac693c78531b3250456.zip
Test::WWW::Mechanize is a subclass of WWW::Mechanize that incorporates
features for web application testing. The Test::WWW::Mechanize::Catalyst module meshes the two to allow easy testing of Catalyst applications without starting up a web server. WWW: http://search.cpan.org/dist/Test-WWW-Mechanize-Catalyst/ PR: ports/89174 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Notes
Notes: svn path=/head/; revision=148654
Diffstat (limited to 'devel/p5-Test-WWW-Mechanize-Catalyst')
-rw-r--r--devel/p5-Test-WWW-Mechanize-Catalyst/Makefile31
-rw-r--r--devel/p5-Test-WWW-Mechanize-Catalyst/distinfo3
-rw-r--r--devel/p5-Test-WWW-Mechanize-Catalyst/pkg-descr13
-rw-r--r--devel/p5-Test-WWW-Mechanize-Catalyst/pkg-plist4
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/p5-Test-WWW-Mechanize-Catalyst/Makefile b/devel/p5-Test-WWW-Mechanize-Catalyst/Makefile
new file mode 100644
index 000000000000..535924905ee6
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-Catalyst/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: p5-Test-WWW-Mechanize-Catalyst
+# Date created: Nov 16, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-WWW-Mechanize-Catalyst
+PORTVERSION= 0.34
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/L/LB/LBROCARD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Test::WWW::Mechanize for Catalyst
+
+BUILD_DEPENDS= p5-Catalyst>=5.00:${PORTSDIR}/www/p5-Catalyst \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-WWW-Mechanize>=1.04:${PORTSDIR}/devel/p5-Test-WWW-Mechanize
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Test::WWW::Mechanize::Catalyst.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-WWW-Mechanize-Catalyst/distinfo b/devel/p5-Test-WWW-Mechanize-Catalyst/distinfo
new file mode 100644
index 000000000000..903b2228484b
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-Catalyst/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-WWW-Mechanize-Catalyst-0.34.tar.gz) = 5cc18a374da612520c5c159efaa21eeb
+SHA256 (Test-WWW-Mechanize-Catalyst-0.34.tar.gz) = 57394d89258a5c172c71cf92b51e84354f8bd7e81dc5807f9b1f47fe433d5b24
+SIZE (Test-WWW-Mechanize-Catalyst-0.34.tar.gz) = 5381
diff --git a/devel/p5-Test-WWW-Mechanize-Catalyst/pkg-descr b/devel/p5-Test-WWW-Mechanize-Catalyst/pkg-descr
new file mode 100644
index 000000000000..76930eec4577
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-Catalyst/pkg-descr
@@ -0,0 +1,13 @@
+Test::WWW::Mechanize is a subclass of WWW::Mechanize that incorporates
+features for web application testing. The Test::WWW::Mechanize::Catalyst
+module meshes the two to allow easy testing of Catalyst applications
+without starting up a web server.
+
+Testing web applications has always been a bit tricky, normally starting
+a web server for your application and making real HTTP requests to it.
+This module allows you to test Catalyst web applications but does not
+start a server or issue HTTP requests. Instead, it passes the HTTP
+request object directly to Catalyst. Thus you do not need to use a real
+hostname: "http://localhost/" will do.
+
+WWW: http://search.cpan.org/dist/Test-WWW-Mechanize-Catalyst/
diff --git a/devel/p5-Test-WWW-Mechanize-Catalyst/pkg-plist b/devel/p5-Test-WWW-Mechanize-Catalyst/pkg-plist
new file mode 100644
index 000000000000..6d43d6e7c0c5
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-Catalyst/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Test/WWW/Mechanize/Catalyst.pm
+@unexec rmdir %D/%%SITE_PERL%%/Test/WWW/Mechanize 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test/WWW 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true