aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Type-Tiny/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-05-25 23:57:11 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-05-25 23:57:11 +0000
commitfb1e9b8aa0d59cf4728e9580ec323f65150ebcd5 (patch)
tree36d26497abc46c13cad85bdcd8b61282e3fc7de9 /devel/p5-Type-Tiny/Makefile
parent33dfb247f2a26a44ec5e721d6cc9ca1f23d13043 (diff)
downloadports-fb1e9b8aa0d59cf4728e9580ec323f65150ebcd5.tar.gz
ports-fb1e9b8aa0d59cf4728e9580ec323f65150ebcd5.zip
- Add p5-Type-Tiny 0.004
Type::Tiny is a tiny class for creating Moose-like type constraint objects which are compatible with Moo, Moose and Mouse. Maybe now we won't need to have separate MooseX, MouseX and MooX versions of everything? We can but hope... This documents the internals of Type::Tiny. Type::Tiny::Manual is a better starting place if you're new. WWW: http://search.cpan.org/dist/Type-Tiny/
Notes
Notes: svn path=/head/; revision=319077
Diffstat (limited to 'devel/p5-Type-Tiny/Makefile')
-rw-r--r--devel/p5-Type-Tiny/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/devel/p5-Type-Tiny/Makefile b/devel/p5-Type-Tiny/Makefile
new file mode 100644
index 000000000000..c4eea06b1bce
--- /dev/null
+++ b/devel/p5-Type-Tiny/Makefile
@@ -0,0 +1,55 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Type-Tiny
+PORTVERSION= 0.004
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:TOBYINK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Tiny, yet Moo(se)-compatible type constraint
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+TEST_DEPENDS= p5-Class-InsideOut>=0:${PORTSDIR}/devel/p5-Class-InsideOut \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-Moo>=0:${PORTSDIR}/devel/p5-Moo \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Mouse>=0:${PORTSDIR}/devel/p5-Mouse \
+ p5-Role-Tiny>=0:${PORTSDIR}/devel/p5-Role-Tiny \
+ p5-Sub-Exporter-Lexical>=0:${PORTSDIR}/devel/p5-Sub-Exporter-Lexical \
+ p5-Validation-Class>=0:${PORTSDIR}/devel/p5-Validation-Class
+
+PERL_CONFIGURE= yes
+
+MAN3= Eval::TypeTiny.3 \
+ Exporter::TypeTiny.3 \
+ Test::TypeTiny.3 \
+ Type::Coercion.3 \
+ Type::Coercion::Union.3 \
+ Type::Library.3 \
+ Type::Params.3 \
+ Type::Tiny.3 \
+ Type::Tiny::Class.3 \
+ Type::Tiny::Duck.3 \
+ Type::Tiny::Enum.3 \
+ Type::Tiny::Intersection.3 \
+ Type::Tiny::Manual.3 \
+ Type::Tiny::Manual::Coercions.3 \
+ Type::Tiny::Manual::Libraries.3 \
+ Type::Tiny::Manual::Params.3 \
+ Type::Tiny::Manual::UsingWithMoo.3 \
+ Type::Tiny::Manual::UsingWithMoose.3 \
+ Type::Tiny::Manual::UsingWithMouse.3 \
+ Type::Tiny::Manual::UsingWithOther.3 \
+ Type::Tiny::Role.3 \
+ Type::Tiny::Union.3 \
+ Type::Utils.3 \
+ Types::Standard.3 \
+ Types::Standard::DeepCoercion.3 \
+ Types::TypeTiny.3
+
+.include <bsd.port.mk>