aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-WeakRef/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-15 16:05:41 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-15 16:05:41 +0000
commit0e7de4a648eabe51c09da08a76a1d53410364032 (patch)
tree9f8e348a07c26429cea305250b383dd78f4c0914 /devel/p5-WeakRef/Makefile
parent62911c0372277b28947f373b240a2cc85a659f53 (diff)
downloadports-0e7de4a648eabe51c09da08a76a1d53410364032.tar.gz
ports-0e7de4a648eabe51c09da08a76a1d53410364032.zip
A patch to Perl 5.005_55 by the author implements a core API for
weak references. This module is a Perl-level interface to that API, allowing weak references to be created in Perl. A weak reference is just like an ordinary Perl reference except that it isn't included in the reference count of the thing referred to. This means that once all references to a particular piece of data are weak, the piece of data is freed and all the weak references are set to undef. This is particularly useful for implementing circular data structures without memory leaks or caches of objects. WWW: http://search.cpan.org/dist/WeakRef/ PR: ports/98963 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Notes
Notes: svn path=/head/; revision=165513
Diffstat (limited to 'devel/p5-WeakRef/Makefile')
-rw-r--r--devel/p5-WeakRef/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/p5-WeakRef/Makefile b/devel/p5-WeakRef/Makefile
new file mode 100644
index 000000000000..a11584cb2988
--- /dev/null
+++ b/devel/p5-WeakRef/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-WeakRef
+# Date created: 14 Jun 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WeakRef
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/L/LU/LUKKA/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= An API to the Perl weak references
+
+PERL_CONFIGURE= yes
+
+MAN3= WeakRef.3
+
+.include <bsd.port.mk>