aboutsummaryrefslogtreecommitdiff
path: root/devel/paexec
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-01-26 08:48:58 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-01-26 08:48:58 +0000
commitc74f2461430d345465ed42a029c0e1da52d10146 (patch)
tree6258cae5e979c4c707c2d2cdd435c621be00c74c /devel/paexec
parentd49664bae724c70263edf6453a30cd3407052a20 (diff)
downloadports-c74f2461430d345465ed42a029c0e1da52d10146.tar.gz
ports-c74f2461430d345465ed42a029c0e1da52d10146.zip
paexec -- Parallel executor, distributes tasks over network.
paexec distributes performing the given tasks across several CPUs or machines on a network and collects the results from those CPUs/machines WWW: http://sourceforge.net/projects/paexec
Notes
Notes: svn path=/head/; revision=206227
Diffstat (limited to 'devel/paexec')
-rw-r--r--devel/paexec/Makefile44
-rw-r--r--devel/paexec/distinfo3
-rw-r--r--devel/paexec/pkg-descr5
-rw-r--r--devel/paexec/pkg-plist18
4 files changed, 70 insertions, 0 deletions
diff --git a/devel/paexec/Makefile b/devel/paexec/Makefile
new file mode 100644
index 000000000000..68b6c77ab282
--- /dev/null
+++ b/devel/paexec/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: paexec
+# Date created: 2008/01/26
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= paexec
+PORTVERSION= 0.6.0
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Parallel executor, distributes tasks over network
+
+LIB_DEPENDS= maa:${PORTSDIR}/devel/libmaa
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+DOCS= ChangeLog NEWS README
+MAN1= paexec.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,2048,4096,; s,x.y.z,${PORTVERSION},' \
+ ${WRKSRC}/paexec.c
+
+do-build:
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} ${LDFLAGS} \
+ *.c -o ${PORTNAME} -lmaa
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/paexec ${DESTDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/paexec.1 ${MAN1PREFIX}/man/man1
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/paexec/distinfo b/devel/paexec/distinfo
new file mode 100644
index 000000000000..c014e123c04e
--- /dev/null
+++ b/devel/paexec/distinfo
@@ -0,0 +1,3 @@
+MD5 (paexec-0.6.0.tar.gz) = d6e9bf5f06eb13591098a5d77339abd2
+SHA256 (paexec-0.6.0.tar.gz) = 41d7d5e6ea63176749d9dbcf8814651c81e8f267de3111c5c4ea214cbad0d50c
+SIZE (paexec-0.6.0.tar.gz) = 16804
diff --git a/devel/paexec/pkg-descr b/devel/paexec/pkg-descr
new file mode 100644
index 000000000000..510275220847
--- /dev/null
+++ b/devel/paexec/pkg-descr
@@ -0,0 +1,5 @@
+paexec distributes performing the given tasks across several CPUs or
+machines on a network and collects the results from those
+CPUs/machines
+
+WWW: http://sourceforge.net/projects/paexec
diff --git a/devel/paexec/pkg-plist b/devel/paexec/pkg-plist
new file mode 100644
index 000000000000..8a082d266bf4
--- /dev/null
+++ b/devel/paexec/pkg-plist
@@ -0,0 +1,18 @@
+bin/paexec
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%EXAMPLESDIR%%/toupper/toupper_cmd
+%%EXAMPLESDIR%%/toupper/toupper_run
+%%EXAMPLESDIR%%/cc_wrapper/cc_wrapper_cmd
+%%EXAMPLESDIR%%/cc_wrapper/cc_wrapper_run
+%%EXAMPLESDIR%%/cc_wrapper/func1.c
+%%EXAMPLESDIR%%/cc_wrapper/func2.c
+%%EXAMPLESDIR%%/cc_wrapper/func3.c
+%%EXAMPLESDIR%%/all_substr/all_substr_cmd
+%%EXAMPLESDIR%%/all_substr/all_substr_run
+@dirrm %%EXAMPLESDIR%%/all_substr
+@dirrm %%EXAMPLESDIR%%/cc_wrapper
+@dirrm %%EXAMPLESDIR%%/toupper
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%