aboutsummaryrefslogtreecommitdiff
path: root/devel/pcre++
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-03-16 07:29:19 +0000
committerPatrick Li <pat@FreeBSD.org>2002-03-16 07:29:19 +0000
commit128097325b9bf657bae496534e08e74f22a03635 (patch)
tree5b32d47cdf608715b0cdfc464d51d508b16999d4 /devel/pcre++
parenta9013ad98f906f1530ce5031bd191325132f7250 (diff)
downloadports-128097325b9bf657bae496534e08e74f22a03635.tar.gz
ports-128097325b9bf657bae496534e08e74f22a03635.zip
Support CXXFLAGS/LOCALBASE properly
PR: 35958 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=56196
Diffstat (limited to 'devel/pcre++')
-rw-r--r--devel/pcre++/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/devel/pcre++/Makefile b/devel/pcre++/Makefile
index 8134c326be0f..38f807be7961 100644
--- a/devel/pcre++/Makefile
+++ b/devel/pcre++/Makefile
@@ -13,19 +13,27 @@ MASTER_SITES= ftp://ftp.daemon.de/scip/Apps/pcre++/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+PCRE_CONFIG?= ${LOCALBASE}/bin/pcre-config
-USE_LIBTOOL= yes
-GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="`${PCRE_CONFIG} --cflags`" \
+ LDFLAGS="`${PCRE_CONFIG} --libs`"
INSTALLS_SHLIB= yes
MAN3= Pcre.3
-.if !defined(NOPORTDOCS)
+post-patch:
+ @${PERL} -pi -e 's|-I/usr/local/include||g ; \
+ s|-L/usr/local/lib||g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-O -g|\@CXXFLAGS\@|g' ${WRKSRC}/Makefile.in
+
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc/html/ ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/*.* ${DOCSDIR}
.endif
.include <bsd.port.mk>