aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-Console_CommandLine
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-21 17:13:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-21 17:13:18 +0000
commit9263980e9fcf66fa9225e1aec7707051d8ac8e90 (patch)
tree7bfa805063b26ce13d94aaa14f5d2773f783aea4 /devel/pear-Console_CommandLine
parent296abb8cdc62973451a7805a86bb98056cecc073 (diff)
downloadports-9263980e9fcf66fa9225e1aec7707051d8ac8e90.tar.gz
ports-9263980e9fcf66fa9225e1aec7707051d8ac8e90.zip
Console_CommandLine is a full featured package for managing command-line
options and arguments highly inspired from python optparse module, it allows the developer to easily build complex command line interfaces. Main features: * handles sub commands (ie. $ myscript.php -q subcommand -f file), * can be completely built from an xml definition file, * generate --help and --version options automatically, * can be completely customized, * builtin support for i18n, * and much more... WWW: http://pear.php.net/package/Console_CommandLine
Notes
Notes: svn path=/head/; revision=204275
Diffstat (limited to 'devel/pear-Console_CommandLine')
-rw-r--r--devel/pear-Console_CommandLine/Makefile41
-rw-r--r--devel/pear-Console_CommandLine/distinfo3
-rw-r--r--devel/pear-Console_CommandLine/pkg-descr13
3 files changed, 57 insertions, 0 deletions
diff --git a/devel/pear-Console_CommandLine/Makefile b/devel/pear-Console_CommandLine/Makefile
new file mode 100644
index 000000000000..73d18f6cd287
--- /dev/null
+++ b/devel/pear-Console_CommandLine/Makefile
@@ -0,0 +1,41 @@
+# Ports collection makefile for: pear-Console_CommandLine
+# Date created: 21 December 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Console_CommandLine
+PORTVERSION= 0.1.1
+CATEGORIES= devel www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A full featured command line options and arguments parser
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= Console
+FILES= CommandLine.php CommandLine/Action.php CommandLine/Command.php\
+ CommandLine/Renderer.php CommandLine/Element.php CommandLine/MessageProvider.php \
+ CommandLine/Outputter.php CommandLine/Result.php CommandLine/Argument.php \
+ CommandLine/Exception.php CommandLine/Option.php CommandLine/XmlParser.php \
+ CommandLine/Action/Callback.php CommandLine/Action/Counter.php \
+ CommandLine/Action/Help.php CommandLine/Action/StoreArray.php \
+ CommandLine/Action/StoreFalse.php CommandLine/Action/StoreFloat.php \
+ CommandLine/Action/StoreInt.php CommandLine/Action/StoreString.php \
+ CommandLine/Action/StoreTrue.php CommandLine/Action/Version.php \
+ CommandLine/MessageProvider/Default.php CommandLine/Outputter/Default.php \
+ CommandLine/Renderer/Default.php
+DATA= xmlschema.rng
+EXAMPLES= ex1.php ex2.php ex2.xml
+_EXAMPLESDIR= docs/examples
+TESTS= console_commandline_addargument.phpt console_commandline_parse_1.phpt \
+ console_commandline_parse_4.phpt tests.inc.php console_commandline_addcommand.phpt \
+ console_commandline_parse_2.phpt console_commandline_parse_5.phpt \
+ console_commandline_addoption.phpt console_commandline_parse_3.phpt \
+ console_commandline_parse_6.phpt
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Console_CommandLine/distinfo b/devel/pear-Console_CommandLine/distinfo
new file mode 100644
index 000000000000..c4b6d4935fb6
--- /dev/null
+++ b/devel/pear-Console_CommandLine/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Console_CommandLine-0.1.1.tgz) = 09a7a98b84a197382d8485dc6282e863
+SHA256 (PEAR/Console_CommandLine-0.1.1.tgz) = 6fe0cf54eec338d8a6850eb3407875f8deb4b7bab4f61fd269c98325a372ff74
+SIZE (PEAR/Console_CommandLine-0.1.1.tgz) = 21270
diff --git a/devel/pear-Console_CommandLine/pkg-descr b/devel/pear-Console_CommandLine/pkg-descr
new file mode 100644
index 000000000000..c299339be715
--- /dev/null
+++ b/devel/pear-Console_CommandLine/pkg-descr
@@ -0,0 +1,13 @@
+Console_CommandLine is a full featured package for managing command-line
+options and arguments highly inspired from python optparse module, it allows
+the developer to easily build complex command line interfaces.
+
+Main features:
+* handles sub commands (ie. $ myscript.php -q subcommand -f file),
+* can be completely built from an xml definition file,
+* generate --help and --version options automatically,
+* can be completely customized,
+* builtin support for i18n,
+* and much more...
+
+WWW: http://pear.php.net/package/Console_CommandLine