aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-HTML_Template_Sigma
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-07-31 14:03:44 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-07-31 14:03:44 +0000
commit9819147600b26c5414d516b0b996010682832b7e (patch)
tree107ed738e77ef84893407bdd1fbb58fc59321818 /devel/pear-HTML_Template_Sigma
parent428da8b230614d520e581407fa2d19e7771600cd (diff)
downloadports-9819147600b26c5414d516b0b996010682832b7e.tar.gz
ports-9819147600b26c5414d516b0b996010682832b7e.zip
Add pear-HTML_Template_Sigma 1.1.2, a PEAR template API.
PR: 83866 Submitted by: Franz Klammer <klammer (at) webonaut.com>
Notes
Notes: svn path=/head/; revision=140560
Diffstat (limited to 'devel/pear-HTML_Template_Sigma')
-rw-r--r--devel/pear-HTML_Template_Sigma/Makefile38
-rw-r--r--devel/pear-HTML_Template_Sigma/distinfo2
-rw-r--r--devel/pear-HTML_Template_Sigma/pkg-descr22
3 files changed, 62 insertions, 0 deletions
diff --git a/devel/pear-HTML_Template_Sigma/Makefile b/devel/pear-HTML_Template_Sigma/Makefile
new file mode 100644
index 000000000000..922542ae8b51
--- /dev/null
+++ b/devel/pear-HTML_Template_Sigma/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: pear-HTML_Template_Sigma
+# Date created: 21 July 2005
+# Whom: Franz Klammer <klammer@webonaut.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_Template_Sigma
+PORTVERSION= 1.1.2
+CATEGORIES= devel www pear
+
+MAINTAINER= klammer@webonaut.com
+COMMENT= PEAR template API
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTML/Template
+FILES= Sigma.php
+EXAMPLES= templates/example_1.html templates/example_2.html templates/example_3.html \
+ templates/example_4.html templates/example_3_add.html \
+ templates/example_3_include.html templates/example_3_replace_1.html \
+ templates/example_3_replace_2.html example_1.php example_2.php \
+ example_3.php example_4.php
+TESTS= templates/addblock.html templates/blockiteration.html templates/blocks.html \
+ templates/callback.html templates/globals.html templates/__include.html \
+ templates/include.html templates/loadtemplatefile.html \
+ templates/replaceblock.html Console_TestListener.php Sigma_api_testcase.php \
+ Sigma_usage_testcase.php Sigma_cache_testcase.php test.php
+_EXAMPLESDIR= docs
+
+do-install-tests-msg: .USE
+ @${ECHO_MSG} " (These tests require PHPUnit - see"
+ @${ECHO_MSG} " <http://pear.php.net/package-info.php?package=PHPUnit>;;)."
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-HTML_Template_Sigma/distinfo b/devel/pear-HTML_Template_Sigma/distinfo
new file mode 100644
index 000000000000..2abf45df6510
--- /dev/null
+++ b/devel/pear-HTML_Template_Sigma/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/HTML_Template_Sigma-1.1.2.tgz) = 6c229f84ccb883dac02b96527a415e87
+SIZE (PEAR/HTML_Template_Sigma-1.1.2.tgz) = 26442
diff --git a/devel/pear-HTML_Template_Sigma/pkg-descr b/devel/pear-HTML_Template_Sigma/pkg-descr
new file mode 100644
index 000000000000..e1fdc91f0af2
--- /dev/null
+++ b/devel/pear-HTML_Template_Sigma/pkg-descr
@@ -0,0 +1,22 @@
+HTML_Template_Sigma implements Integrated Templates API designed by Ulf Wendel.
+
+Features:
+ * Nested blocks. Nesting is controlled by the engine.
+ * Ability to include files from within template: <!-- INCLUDE -->
+ * Automatic removal of empty blocks and unknown variables
+ (methods to manually tweak/override this are also available)
+ * Methods for runtime addition and replacement of blocks in templates
+ * Ability to insert simple function calls into templates:
+ func_uppercase('Hello world!') and to define callback functions for these
+ * 'Compiled' templates: the engine has to parse a template file using regular
+ expressions to find all the blocks and variable placeholders.
+ This is a very "expensive" operation and is an overkill to do on every page
+ request: templates seldom change on production websites.
+ Thus this feature: an internal representation of the template structure is
+ saved into a file and this file gets loaded instead of the source one on
+ subsequent requests (unless the source changes)
+ * PHPUnit-based tests to define correct behaviour
+ * Usage examples for most of the features are available, look in the docs/
+ directory
+
+WWW: http://pear.php.net/package-info.php?package=HTML_Template_Sigma