aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-PHPUnit3
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-29 17:01:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-29 17:01:20 +0000
commitda638607237e83294b0f22f2b9f053d0f0e627ff (patch)
treefe30f471ff876b471f68074b28be4bb5ba052b99 /devel/pear-PHPUnit3
parent97df964f6e00d60b1fe0f928c97374a785fed12f (diff)
downloadports-da638607237e83294b0f22f2b9f053d0f0e627ff.tar.gz
ports-da638607237e83294b0f22f2b9f053d0f0e627ff.zip
- Unbreak
- Got this port working again after making some minor changes to the devel/pear port to support alternate download locations. Submitted by: Greg Larkin <glarkin@sourcehosting.net> Approved by: maintainer (via icq)
Notes
Notes: svn path=/head/; revision=202316
Diffstat (limited to 'devel/pear-PHPUnit3')
-rw-r--r--devel/pear-PHPUnit3/Makefile8
-rw-r--r--devel/pear-PHPUnit3/files/pear-deinstall.in27
-rw-r--r--devel/pear-PHPUnit3/files/pear-install.in19
3 files changed, 51 insertions, 3 deletions
diff --git a/devel/pear-PHPUnit3/Makefile b/devel/pear-PHPUnit3/Makefile
index 51e594f6dde3..bcdbe678e4c9 100644
--- a/devel/pear-PHPUnit3/Makefile
+++ b/devel/pear-PHPUnit3/Makefile
@@ -17,15 +17,17 @@ COMMENT= PEAR regression testing framework for unit tests
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= Does not fetch
-
-CONFLICTS= *PHPUnit*
+CONFLICTS= PHPUnit-[0-9]*
LATEST_LINK= pear-${PORTNAME}
OPTIONS= PEAR_LOG "PEAR::Log support" off \
JSON "Enable JSON support" off \
CHANNEL= pear.phpunit.de
+SUB_FILES= pear-deinstall pear-install
+SUB_LIST+= CHANNEL=${CHANNEL}
+PKGINSTALL= ${WRKDIR}/pear-install
+PKGDEINSTALL= ${WRKDIR}/pear-deinstall
DEFAULT_PHP_VER=5
IGNORE_WITH_PHP=4
diff --git a/devel/pear-PHPUnit3/files/pear-deinstall.in b/devel/pear-PHPUnit3/files/pear-deinstall.in
new file mode 100644
index 000000000000..ccbf7b82cb25
--- /dev/null
+++ b/devel/pear-PHPUnit3/files/pear-deinstall.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Remove package declaration from PEAR's registry and optionally delete
+# a non-standard channel.
+
+if [ x$2 != xDEINSTALL -a x$2 != xPOST-DEINSTALL ]; then
+ exit
+fi
+PKG_NAME=${1%%-[0-9._]*}
+PACKAGE=$(echo $PKG_NAME | sed 's/pear-//')
+
+PEAR=${PKG_PREFIX}/bin/pear
+CHANNEL=%%CHANNEL%%
+
+if [ "$2" = "DEINSTALL" ]; then
+ if [ "x${CHANNEL}" != "x" ]; then
+ ${PEAR} uninstall -r -n ${CHANNEL}/${PACKAGE} || true
+ else
+ ${PEAR} uninstall -r -n ${PACKAGE} || true
+ fi
+else
+ if [ "x${CHANNEL}" != "x" ]; then
+ ${PEAR} channel-delete ${CHANNEL}
+ fi
+fi
diff --git a/devel/pear-PHPUnit3/files/pear-install.in b/devel/pear-PHPUnit3/files/pear-install.in
new file mode 100644
index 000000000000..2ec01250b2f3
--- /dev/null
+++ b/devel/pear-PHPUnit3/files/pear-install.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Register the package $1 in the port registry and optionally add a
+# non-standard channel.
+
+PREFIX=${PKG_PREFIX:=%%PREFIX%%}
+PEAR=${PREFIX}/bin/pear
+PKGREGDIR=${PREFIX}/share/pear/packages/$1
+CHANNEL=%%CHANNEL%%
+
+[ "x$1" = "x" ] && exit 1
+if [ "x$2" = "xPOST-INSTALL" ]; then
+ if [ "x${CHANNEL}" != "x" ]; then
+ ${PEAR} channel-add http://${CHANNEL}/channel.xml
+ fi
+ ${PEAR} install -r -n -f ${PKGREGDIR}/package.xml
+fi